summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-06-23 18:10:10 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-06-24 14:33:23 +0200
commit95b8edd4aab48f4cb66f3119e91e59ab74f907e9 (patch)
tree16ab8f0ac5ba32e6741849eede7610bcfe844925
parent49bd9e1a1e787e308146e4e4a1cd320ddb7e7ece (diff)
Make the agl-compositor the default compositor
This makes the agl-compositor the default starting with Jumping Jellyfish For development purposes, you have these variables at hand to influence the setup: AGL_DEFAULT_WESTONSTART AGL_DEFAULT_WM_SHELL Check your conf/local.conf for details. Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Change-Id: Iceb35375e04f947009800b80511f6360026403fe
-rw-r--r--meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend4
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb6
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend7
-rw-r--r--templates/base/99_local.conf.inc14
-rw-r--r--templates/feature/agl-compositor/50_local.conf.inc48
-rw-r--r--templates/feature/agl-compositor/README_feature_agl-compositor.md13
6 files changed, 25 insertions, 67 deletions
diff --git a/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend b/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
index 6472c7eff..85ebc29d6 100644
--- a/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
@@ -24,12 +24,12 @@ SRC_URI_append = "\
file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
"
-DEFAULT_WM_SHELL = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-compositor', 'xdg-shell', 'ivi-shell', d)}"
+AGL_DEFAULT_WM_SHELL ?= "xdg-shell"
AFM_CONF_DIR = "${D}${sysconfdir}/afm/unit.env.d"
QT_SHELL_FILE = "${AFM_CONF_DIR}/qt-shell"
do_install_append_class-target() {
mkdir -p ${AFM_CONF_DIR}
- echo "QT_WAYLAND_SHELL_INTEGRATION=${DEFAULT_WM_SHELL}" > ${QT_SHELL_FILE}
+ echo "QT_WAYLAND_SHELL_INTEGRATION=${AGL_DEFAULT_WM_SHELL}" > ${QT_SHELL_FILE}
echo "QT_WAYLAND_RESIZE_AFTER_SWAP=1" >> ${QT_SHELL_FILE}
}
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb b/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb
index c0e2d9895..41f5f027b 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb
@@ -18,4 +18,8 @@ S = "${WORKDIR}/git"
inherit meson pkgconfig python3native
-FILES_${PN} = "${bindir}/agl-compositor ${datadir}/${PN}/protocols/agl-shell.xml ${datadir}/${PN}/protocols/agl-shell-desktop.xml"
+FILES_${PN} = " \
+ ${bindir}/agl-compositor \
+ ${datadir}/${PN}/protocols/agl-shell.xml \
+ ${datadir}/${PN}/protocols/agl-shell-desktop.xml \
+ "
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
index ddabff5f5..374e9aa75 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
@@ -2,9 +2,10 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
inherit agl-graphical
-WESTONSTART ??= "${@bb.utils.contains("DISTRO_FEATURES", "agl-compositor", "/usr/bin/agl-compositor", "/usr/bin/weston",d)} ${WESTONARGS}"
-WESTONSTART_append = " ${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", " --log=${DISPLAY_XDG_RUNTIME_DIR}/weston.log", "",d)}"
-WESTONSTART_append = " ${@bb.utils.contains("DISTRO_FEATURES", "agl-compositor", " --config ${sysconfdir}/xdg/weston/weston.ini", "",d)}"
+AGL_DEFAULT_WESTONSTART ??= "/usr/bin/agl-compositor --config ${sysconfdir}/xdg/weston/weston.ini"
+
+WESTONSTART ??= "${AGL_DEFAULT_WESTONSTART} ${WESTONARGS}"
+WESTONSTART_append = " ${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", " --log=${DISPLAY_XDG_RUNTIME_DIR}/compositor.log", "",d)}"
WIFILES = " \
file://weston.conf.in \
diff --git a/templates/base/99_local.conf.inc b/templates/base/99_local.conf.inc
index 871ea0ebf..c4f43998b 100644
--- a/templates/base/99_local.conf.inc
+++ b/templates/base/99_local.conf.inc
@@ -17,3 +17,17 @@
# Additional free disk space created in the image in Kbytes.
#IMAGE_ROOTFS_EXTRA_SPACE="524288"
+# meta-agl/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
+# AGL's compositor is started instead of weston like so
+# AGL_DEFAULT_WESTONSTART ?= "/usr/bin/agl-compositor --config ${sysconfdir}/xdg/weston/weston.ini"
+# you can redefine it using this variable to go back to weston,
+# but be careful that this needs further changes to work !
+# Especially the AGL demo apps will not work as-is.
+#AGL_DEFAULT_WESTONSTART = "/usr/bin/weston"
+
+# meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
+# This defines the QT integration. We default to xdg-shell
+# AGL_DEFAULT_WM_SHELL ?= "xdg-shell"
+# you can redefine it using this variable to e.g. use ivi-shell
+# but be careful that this needs further changes to work !
+#AGL_DEFAULT_WM_SHELL = ""
diff --git a/templates/feature/agl-compositor/50_local.conf.inc b/templates/feature/agl-compositor/50_local.conf.inc
deleted file mode 100644
index 557b331a6..000000000
--- a/templates/feature/agl-compositor/50_local.conf.inc
+++ /dev/null
@@ -1,48 +0,0 @@
-DISTRO_FEATURES_append = " agl-compositor"
-
-# note that these are for testing only, should be removed once the changes
-# land in their respective repositories
-
-# shell client
-AGL_BRANCH_pn-homescreen = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-homescreen = "${AUTOREV}"
-DEPENDS_append_pn-homescreen = " wayland-native wayland qtwayland qtwayland-native"
-
-# normal apps
-AGL_BRANCH_pn-launcher = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-launcher = "${AUTOREV}"
-DEPENDS_append_pn-launcher = " wayland-native wayland qtwayland qtwayland-native"
-AGL_BRANCH_pn-hvac = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-hvac = "${AUTOREV}"
-DEPENDS_append_pn-hvac = " libafb-helpers-qt"
-AGL_BRANCH_pn-ondemandnavi = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-ondemandnavi = "${AUTOREV}"
-AGL_BRANCH_pn-mediaplayer = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-mediaplayer = "${AUTOREV}"
-AGL_BRANCH_pn-alexa-viewer = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-alexa-viewer = "${AUTOREV}"
-DEPENDS_append_pn-alexa-viewer = " wayland-native wayland qtwayland qtwayland-native"
-AGL_BRANCH_pn-onscreenapp = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-onscreenapp = "${AUTOREV}"
-AGL_BRANCH_pn-settings = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-settings = "${AUTOREV}"
-
-# other apps
-AGL_BRANCH_pn-radio = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-radio = "${AUTOREV}"
-AGL_BRANCH_pn-dashboard = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-dashboard = "${AUTOREV}"
-AGL_BRANCH_pn-taskmanager = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-taskmanager = "${AUTOREV}"
-AGL_BRANCH_pn-phone = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-phone = "${AUTOREV}"
-AGL_BRANCH_pn-poiapp = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-poiapp = "${AUTOREV}"
-AGL_BRANCH_pn-mixer = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-mixer = "${AUTOREV}"
-AGL_BRANCH_pn-messaging = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-messaging = "${AUTOREV}"
-
-# use agl-service-homescreen
-AGL_BRANCH_pn-agl-service-homescreen = "sandbox/mvlad/agl-compositor"
-SRCREV_pn-agl-service-homescreen = "${AUTOREV}"
diff --git a/templates/feature/agl-compositor/README_feature_agl-compositor.md b/templates/feature/agl-compositor/README_feature_agl-compositor.md
deleted file mode 100644
index 4b5211ee7..000000000
--- a/templates/feature/agl-compositor/README_feature_agl-compositor.md
+++ /dev/null
@@ -1,13 +0,0 @@
----
-description: Feature agl-compositor
-authors: Daniel Stone <daniels@collabora.com>
----
-
-### Feature agl-compositor
-
-_agl-compositor_ is a new Wayland display server framework, based on the
-existing libweston library. It provides AGL users an extensible framework for
-window/input/output management within the display server.
-
-It is included as a technology preview, and is not currently ready for
-production use.