summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-12-03 13:01:20 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-07 14:34:39 +0000
commit92025c353f298a2c6f8df814e650cfc61df6f13b (patch)
treef84c43ae2dbaffc8bf9cf50acde153fb42e9db49
parentf092b22cc526462f8be4824003e18f0e11d95263 (diff)
meta-agl-profile-core: update pyagl SRCREV
Update pyagl SRCREV to pick up: 9a7c3f4 Add HVAC bindings and tests 01131b1 Add marks for Internet requiring tests 31737ec Add simple wrapper script ca505ea Add CAN value tests 10a4867 Allow pyagl CAN test test_write_wo_auth to xfail Also add installation of the new wrapper script as /usr/bin/pyagl. Bug-AGL: SPEC-3648, SPEC-3684, SPEC-3685, SPEC-3660 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I251d25b5bf7dd1134cbf22c0352875e1a615ddd8 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25721 ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb b/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
index 05e657e2d..7a4f3b6a5 100644
--- a/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
+++ b/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
@@ -4,13 +4,17 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/pyagl;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "6703d65bc91054d512fccb57a4275b30319a88d7"
+SRCREV = "9a7c3f431355d6f4a15ec67a6d7261b0cbfc85d5"
PV = "${AGL_BRANCH}+git${SRCPV}"
S = "${WORKDIR}/git"
inherit setuptools3
+do_install_append() {
+ install -D -m 0755 ${S}/pyagl/scripts/pyagl ${D}${bindir}/pyagl
+}
+
RDEPENDS_${PN} += " \
python3-asyncio \
python3-asyncssh \