summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-12-01 15:16:36 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-12-02 16:56:47 +0000
commit122938588ea50c46116b31c0912b79f979b8678d (patch)
tree82d96afd14372f017a8aefdc9b4373c1e724f874
parentf4235a45f1c0b01208a67de94637f73b0d5ad6d4 (diff)
Add sublayer for new application framework components
Setup the layer and a scripts/run-yocto-check-layer.sh . Bug-AGL: SPEC-4161 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I762773107ada7263b854b2f9ea54d1f11adf1487 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26945 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
-rw-r--r--meta-app-framework/conf/layer.conf16
-rwxr-xr-xmeta-app-framework/scripts/run-yocto-check-layer.sh37
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-app-framework/conf/layer.conf b/meta-app-framework/conf/layer.conf
new file mode 100644
index 000000000..b82d8a19a
--- /dev/null
+++ b/meta-app-framework/conf/layer.conf
@@ -0,0 +1,16 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "meta-app-framework"
+BBFILE_PATTERN_meta-app-framework = "^${LAYERDIR}/"
+BBFILE_PRIORITY_meta-app-framework = "60"
+
+LAYERSERIES_COMPAT_meta-app-framework = "dunfell"
+LAYERDEPENDS_meta-app-framework = "core aglcore"
+
+#
+LICENSE_PATH += "${LAYERDIR}/licenses"
diff --git a/meta-app-framework/scripts/run-yocto-check-layer.sh b/meta-app-framework/scripts/run-yocto-check-layer.sh
new file mode 100755
index 000000000..62377d34e
--- /dev/null
+++ b/meta-app-framework/scripts/run-yocto-check-layer.sh
@@ -0,0 +1,37 @@
+#!/bin/bash
+#set -x
+
+SCRIPTPATH="$( cd $(dirname $0) >/dev/null 2>&1 ; pwd -P )"
+echo $SCRIPTPATH
+AGLROOT="$SCRIPTPATH/../../.."
+POKYDIR="$AGLROOT/external/poky"
+TMPROOT=`mktemp -d`
+
+rm -rf ${TMPROOT}/testbuild-ycl || true
+mkdir -p ${TMPROOT}/testbuild-ycl
+cd ${TMPROOT}/testbuild-ycl
+
+source $POKYDIR/oe-init-build-env .
+
+cat << EOF >> conf/local.conf
+# just define defaults
+AGL_FEATURES ?= ""
+AGL_EXTRA_IMAGE_FSTYPES ?= ""
+
+# important settings imported from poky-agl.conf
+# we do not import
+DISTRO_FEATURES:append = " systemd"
+DISTRO_FEATURES_BACKFILL_CONSIDERED:append = " sysvinit"
+VIRTUAL-RUNTIME_init_manager = "systemd"
+
+EOF
+
+
+yocto-check-layer \
+ --dependency \
+ $AGLROOT/meta-agl/meta-agl-core \
+ -- \
+ $AGLROOT/meta-agl/meta-app-framework
+
+
+[ $? = 0 ] && rm -rf ${TMPROOT}/testbuild-ycl