summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <paul.barker@sancloud.com>2021-12-06 18:25:28 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-12-07 22:59:57 +0000
commit6a76ace5052a86b382c05649da802094f491e031 (patch)
tree6cf35b600204bec283bce286faaa436d81a5d920
parent9ec9843dcba7f38f8e005ca4251ad71d6681c234 (diff)
meta-agl-bsp: ti: Refresh ti-sgx-ddk-km patch
After updating the meta-ti layer to the TI CoreSDK 08.00.00.004 release, the patch to the ti-sgx-ddk-km recipe (aka PowerVR drivers) needs refreshing. Bug-AGL: SPEC-4156 Signed-off-by: Paul Barker <paul.barker@sancloud.com> Change-Id: I18034ea967c96f867e30399e8f3045b066ffd2b7 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26970 Reviewed-by: Scott Murray <scott.murray@konsulko.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/meta-ti/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch b/meta-agl-bsp/meta-ti/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch
index 93aff157a..9e0c7e6a7 100644
--- a/meta-agl-bsp/meta-ti/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch
+++ b/meta-agl-bsp/meta-ti/recipes-bsp/ti-sgx-ddk-km/ti-sgx-ddk-km/0001-Add-support-for-AGL-toolchain.patch
@@ -1,30 +1,30 @@
-From 11131a5e778d19c06eefbcf61447c6efbcee0613 Mon Sep 17 00:00:00 2001
-From: Paul Barker <paul.barker@sancloud.co.uk>
-Date: Mon, 18 Nov 2019 08:47:41 +0000
+From 3bc2dac0d32038e82d9fec17bee5b66a73c2937c Mon Sep 17 00:00:00 2001
+From: Paul Barker <paul.barker@sancloud.com>
+Date: Tue, 30 Nov 2021 16:48:58 +0000
Subject: [PATCH] Add support for AGL toolchain
We can use the pre-existing config for arm-linux-gnueabihf, we just need
to make sure our toolchain is matched against this and not
arm-linux-gnueabi.
-Signed-off-by: Paul Barker <paul.barker@sancloud.co.uk>
+Signed-off-by: Paul Barker <paul.barker@sancloud.com>
---
eurasia_km/eurasiacon/build/linux2/config/compiler.mk | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/eurasia_km/eurasiacon/build/linux2/config/compiler.mk b/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
-index 2ba3e5e..03e86c5 100644
+index 97b90e2bc8ce..4e4a6d9c737f 100644
--- a/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
+++ b/eurasia_km/eurasiacon/build/linux2/config/compiler.mk
@@ -68,7 +68,7 @@ define calculate-compiler-preferred-target
ifneq ($$(filter aarch64-%,$$($(1)_compiler_preferred_target)),)
$(1)_compiler_preferred_target := aarch64-linux-gnu
endif
-- ifneq ($$(filter arm-%-gnueabihf arm-oe-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
-+ ifneq ($$(filter arm-%-gnueabihf arm-oe-linux-gnueabi arm-agl-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
+- ifneq ($$(filter arm-%-gnueabihf arm-oe-linux-gnueabi arm-poky-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
++ ifneq ($$(filter arm-%-gnueabihf arm-oe-linux-gnueabi arm-poky-linux-gnueabi arm-agl-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
$(1)_compiler_preferred_target := arm-linux-gnueabihf
endif
ifneq ($$(filter arm-%-gnueabi armv7a-cros-linux-gnueabi armv7hl-redhat-linux-gnueabi,$$($(1)_compiler_preferred_target)),)
--
-2.17.1
+2.31.1