summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-06-14 18:05:47 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-06-23 11:15:27 +0000
commit0e46641fff1e0c17db769eb7c7204a9e0b495ae4 (patch)
tree6194b2ffaa707147056b63bfeccd91d041d476b8
parent2837293f04776ab51f36b4dd52a6d046fca4d47b (diff)
rcar3: move extra kernel modules to MACHINE_EXTRA_RRECOMMENDS
The appending of the rcar3 graphics related kernel modules to IMAGE_INSTALL in agl_rcar.inc is problematic for users building headless or container targetted images. To avoid this, instead append them to MACHINE_EXTRA_RRECOMMENDS, which will result in them being pulled in via packagegroup-machine-base. Users not desiring them can then either disable package recommendations or not pull in packagegroup-machine-base. In practice, this has no effect on any of the current images in meta-agl-core or meta-agl-demo, but it is required for the IC EG guest container build for rcar3 platforms. Bug-AGL: SPEC-3983 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I309926b6dc31614fb7c710b0a302716942d07df8 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26430 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar.inc4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-agl-bsp/conf/include/agl_rcar.inc b/meta-agl-bsp/conf/include/agl_rcar.inc
index cfdff9dbf..1fd563960 100644
--- a/meta-agl-bsp/conf/include/agl_rcar.inc
+++ b/meta-agl-bsp/conf/include/agl_rcar.inc
@@ -40,7 +40,9 @@ DISTRO_FEATURES_append = " h264dec_lib h264enc_lib aaclcdec_lib aaclcdec_mdw"
# testing shows no issues on H3ULCB when not having them.
BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend"
-IMAGE_INSTALL_append_rcar-gen3 = " \
+# Add graphics and decoder drivers to packagegroup-machine-base
+# recommendation.
+MACHINE_EXTRA_RRECOMMENDS_append_rcar-gen3 = " \
kernel-module-pvrsrvkm \
kernel-module-vsp2 \
kernel-module-vspm \