summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorentin Labbe <clabbe@baylibre.com>2019-06-17 13:18:06 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-21 11:30:54 +0000
commit075d872edc9fbec1463e0ef164a2db88f5f5427b (patch)
tree406727f21d0a0d9c17d323e67e4bab6ffe955e97
parent576cd930a78ab554cf3d805e65b9cf13d1d77ade (diff)
SPEC-2376: Add config for QEMU arm kernels
The default yocto qemuarm machine is versatilepb which is not the right choice for AGL (ex: Max 256M of RAM). This patchs change qemuarm configs for using the virt machine. Change-Id: Ib5e0ae801ba152318a2455763b1a2f1020d1858e Bug-AGL: SPEC-2376 Signed-off-by: Corentin Labbe <clabbe@baylibre.com>
-rw-r--r--meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/qemuarm.cfg6
-rw-r--r--meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/virtio.cfg2
-rw-r--r--meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend3
3 files changed, 11 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/qemuarm.cfg b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/qemuarm.cfg
new file mode 100644
index 000000000..e71c714d6
--- /dev/null
+++ b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/qemuarm.cfg
@@ -0,0 +1,6 @@
+# Necessary configs for using the virt qemu machine
+CONFIG_ARCH_MULTI_V7=y
+CONFIG_ARCH_VIRT=y
+CONFIG_SERIAL_AMBA_PL011=y
+CONFIG_PCI_HOST_GENERIC=y
+CONFIG_RTC_DRV_PL031=y
diff --git a/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/virtio.cfg b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/virtio.cfg
index 9bdc2c64e..d042d7d64 100644
--- a/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/virtio.cfg
+++ b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/virtio.cfg
@@ -2,3 +2,5 @@
CONFIG_BLK_MQ_VIRTIO=y
CONFIG_VIRTIO=y
CONFIG_VIRTIO_BLK=y
+# qemuarm need virtionet
+CONFIG_VIRTIO_NET=y
diff --git a/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend
index d8a583926..e97b8f9d1 100644
--- a/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -8,6 +8,9 @@ SRC_URI += "file://hciattach.cfg \
# Enable some things on qemuarm64 so MOST drivers will build and load.
SRC_URI_append_qemuarm64 = " file://most_deps.cfg"
+# Configuration for using the virt machine (and not versatilepb)
+SRC_URI_append_qemuarm = " file://qemuarm.cfg"
+
# Build a generic v7 kernel instead of the arm926j one that upstream
# qemuarm defaults to.
KBUILD_DEFCONFIG_qemuarm = "multi_v7_defconfig"