summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@konsulko.com>2019-11-10 00:39:42 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-12-03 15:09:19 +0000
commit2fa5dae62868c63781568eeb5435ed3296c2ddc2 (patch)
treea18cfd9ea20e61b3093b4d1ca6d9ad850dab96eb
parent11a613bab398e60d8a9da1eb0d6c4c754fd8bfef (diff)
Extend intel-corei7-64 machine to support virtual targets
These changes allow images built for the intel-corei7-64 machine to be booted under qemu (by using the normal `runqemu` command) and vmware or virtualbox after a build. Functionality on real hardware should not be compromised. Bug-AGL: SPEC-2931 Change-Id: If25782bf59e145cab32a4c9a0e39b599106ce7cc Signed-off-by: Paul Barker <pbarker@konsulko.com>
-rw-r--r--meta-agl-bsp/conf/include/agl_intel-corei7-64.inc16
-rw-r--r--meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/mesa/mesa_%.bbappend1
-rw-r--r--meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/wayland/weston-ini-conf.bbappend3
-rw-r--r--meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers_%.bbappend1
-rw-r--r--meta-netboot/classes/netboot.bbclass2
5 files changed, 21 insertions, 2 deletions
diff --git a/meta-agl-bsp/conf/include/agl_intel-corei7-64.inc b/meta-agl-bsp/conf/include/agl_intel-corei7-64.inc
index 39ed66880..68398371b 100644
--- a/meta-agl-bsp/conf/include/agl_intel-corei7-64.inc
+++ b/meta-agl-bsp/conf/include/agl_intel-corei7-64.inc
@@ -5,7 +5,7 @@ IMAGE_INSTALL_append = " \
intel-vaapi-driver \
gstreamer1.0-vaapi"
-AGL_EXTRA_IMAGE_FSTYPES = "wic.xz wic.bmap wic.xz.sha256sum"
+AGL_EXTRA_IMAGE_FSTYPES = "wic.xz wic.bmap wic.xz.sha256sum ext4 wic.vmdk"
INITRD_LIVE = "${DEPLOY_DIR_IMAGE}/${INITRD_IMAGE_LIVE}-${MACHINE}.ext4.gz"
# Modify this file under meta-agl-bsp/meta-intel/wic to change the
@@ -16,3 +16,17 @@ PREFERRED_VERSION_linux-intel ?= "4.19%"
PREFERRED_VERSION_linux-intel-rt ?= "4.19%"
SERIAL_CONSOLES_remove = "115200;ttyS2"
+
+#
+# To avoid corrupt boot screen by systemd message, you can use serial
+# console separated from VGA console or disable all boot messages by
+# kernel command line.
+#
+# Configuration for serial console
+QB_KERNEL_CMDLINE_APPEND_append = " console=ttyS0,115200n8"
+#
+# All boot message will be off
+QB_KERNEL_CMDLINE_APPEND_append = " quiet"
+#
+# Force the virtio video device as 'vmware' doesn't always work
+QB_OPT_APPEND_append = " -vga virtio"
diff --git a/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/mesa/mesa_%.bbappend b/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/mesa/mesa_%.bbappend
index 49e527707..8ac343aa3 100644
--- a/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/mesa/mesa_%.bbappend
+++ b/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/mesa/mesa_%.bbappend
@@ -2,5 +2,6 @@
GALLIUM_LLVM = "gallium-llvm"
PACKAGECONFIG_append_qemux86 = " gallium ${GALLIUM_LLVM}"
PACKAGECONFIG_append_qemux86-64 = " gallium ${GALLIUM_LLVM}"
+PACKAGECONFIG_append_intel-corei7-64 = " gallium ${GALLIUM_LLVM}"
DRIDRIVERS_append_intel-corei7-64 = ",i965"
diff --git a/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/wayland/weston-ini-conf.bbappend
index 8fa08bc3b..916bd6f3d 100644
--- a/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -7,3 +7,6 @@ OVERRIDES_prepend_qemux86-64 = "virtualmachine:"
# Switch to the Virtual section that we have when a valid DRM device is found
SRC_URI_remove_virtualmachine = "file://hdmi-a-1-270.cfg"
SRC_URI_append_virtualmachine = " file://virtual.cfg"
+
+# For intel-corei7-64 we want to support both the HDMI-A-1 and Virtual-1 outputs
+SRC_URI_append_intel-corei7-64 = " file://virtual.cfg"
diff --git a/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers_%.bbappend b/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers_%.bbappend
new file mode 100644
index 000000000..c87b36c17
--- /dev/null
+++ b/meta-agl-bsp/recipes-support/vboxguestdrivers/vboxguestdrivers_%.bbappend
@@ -0,0 +1 @@
+COMPATIBLE_MACHINE = "(qemux86|qemux86-64|intel-corei7-64)"
diff --git a/meta-netboot/classes/netboot.bbclass b/meta-netboot/classes/netboot.bbclass
index 85a0ead01..63369285f 100644
--- a/meta-netboot/classes/netboot.bbclass
+++ b/meta-netboot/classes/netboot.bbclass
@@ -1,7 +1,7 @@
# Enable network bootable image and initrd/initramfs
python () {
- if (bb.utils.contains_any("IMAGE_FSTYPES",["live","wic.vmdk"],True,False,d)):
+ if (bb.utils.contains("IMAGE_FSTYPES","live",True,False,d)):
# typical case for Minnowboard Max
d.setVar("INITRD_IMAGE","initramfs-netboot-image")
d.setVar("INITRD_IMAGE_LIVE",d.getVar("INITRD_IMAGE",True))