summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-06-23 14:12:40 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-06-23 16:39:21 +0000
commit65f8170e4e060f7c3b3eb8cb4d76d7e804e1a688 (patch)
treea5daf857683d0b9eb8dc8d6a7bcc8b37b308c844
parente46f5db0ed37fe912ed2f97e27280e8c681e547b (diff)
af-main: Fix service and their socket activation
The method to create shared services using websockets was buggy. This patch correct it. It creates the directories 'sockets.target.wants' were the socket activations units will be linked. It also makes correct reload and improves the used paths. Also fixes a masty infinite loop (spec-663). AGL-Bug: SPEC-670 AGL-Bug: SPEC-663 Change-Id: I39d93f669498354a1c2f96bd735c0318a2f0e93a Signed-off-by: José Bollo <jose.bollo@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9787 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Romain Forlot <romain.forlot@iot.bzh> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb2
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.inc2
2 files changed, 3 insertions, 1 deletions
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index 5cc574086..b71a4cba3 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -64,6 +64,8 @@ do_install_append_class-target() {
install -d -m 0775 ${D}${systemd_units_root}/user
install -d -m 0775 ${D}${systemd_units_root}/system/default.target.wants
install -d -m 0775 ${D}${systemd_units_root}/user/default.target.wants
+ install -d -m 0775 ${D}${systemd_units_root}/system/sockets.target.wants
+ install -d -m 0775 ${D}${systemd_units_root}/user/sockets.target.wants
install -d ${D}${afm_datadir}/applications
install -d ${D}${afm_datadir}/icons
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
index 3317f433b..5041c8da1 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
@@ -14,7 +14,7 @@ SRC_URI = "${SRC_URI_git} \
${SRC_URI_files} \
"
-SRCREV = "d266bd8816f5a2647e011f5b23698bf2d788b91b"
+SRCREV = "474616e64fe081a59ebdb7ee6d650778f318212a"
S = "${WORKDIR}/git"