summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-07-28 23:44:08 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-07-29 23:08:49 +0000
commit750faf16a6173f8d45bcc9751fa60b90c8f807e5 (patch)
tree3defbaa34c06006a94aa6180d312516f4b8c5857
parent8d2bcfc384c9e7464ffc77343c0b094e0e65b285 (diff)
Fix a dependency issue when building the SDK
When using -c populate_sdk, then the -dev packages are installed. There is a hard dependency of the -dev package on the package. As we have multiple subtypes here and switch using ALTERNATIVES, this collides in this corner case. Fix it by not creating a -dev package in the first place as it is not needed here anyway. Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I21326c9edc5cb7571ed94593eae1075cf56353db Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27841 Reviewed-by: Scott Murray <scott.murray@konsulko.com> Reviewed-by: Marius Vlad <marius.vlad@collabora.com> Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
index c04ff6568..9eea06adc 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
@@ -120,3 +120,7 @@ RPROVIDES:${PN}-landscape-inverted = "weston-ini"
RCONFLICTS:${PN}-landscape-inverted = "${PN}"
ALTERNATIVE:${PN}-landscape-inverted = "weston.ini"
ALTERNATIVE_TARGET_${PN}-landscape-inverted = "${weston_ini_dir}/weston.ini.landscape-inverted"
+
+# This is a settings-only package, we do not need a development package
+# (and its fixed dependency to ${PN} being installed)
+PACKAGES:remove = "${PN}-dev ${PN}-staticdev"