summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-03-24 11:16:21 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-03-30 07:36:39 +0000
commit7d1d7457ff2b71abe95525b26148d5a3e7a42790 (patch)
treec7b9796ea099f94da5b879276235fea6077d6bf4
parent64d59ff0e0e835a53445b07257d3896fb48abfb5 (diff)
Generate weston.ini dynamically
* remove weston-intel.ini * add new package weston-ini-conf * the list of the sections of weston.ini is described in variable flags WESTONSECTION * each section is described in variable flags WESTONSECTION * each output screen is described in agl_screen variable Bug-AGL: SPEC-477 Change-Id: I3d25ab49018e3842c916993ba8b9bcc2428d5170 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
-rw-r--r--meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston/weston-intel.ini21
-rw-r--r--meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston_%.bbappend15
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston-qcom.ini13
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend6
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend4
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini19
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend6
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend1
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston/weston-rcar.ini11
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend16
-rw-r--r--meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend5
-rw-r--r--meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini20
-rw-r--r--meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend15
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston/dra7xx-evm/weston.ini11
-rw-r--r--meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf.bbappend17
-rw-r--r--meta-agl-bsp/recipes-graphics/wayland/weston_%.bbappend21
-rw-r--r--meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb2
-rw-r--r--meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf36
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf.bb57
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf/screen.inc4
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_DSI.inc2
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_GeChic.inc4
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_dell.inc2
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_qemu.inc16
-rw-r--r--meta-agl/recipes-graphics/wayland/weston/weston.ini7
-rw-r--r--meta-agl/recipes-graphics/wayland/weston_%.bbappend9
-rw-r--r--meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-graphics.bb2
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell-config.bb14
-rw-r--r--meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell/weston.ini.ivi-shell99
29 files changed, 150 insertions, 305 deletions
diff --git a/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston/weston-intel.ini b/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston/weston-intel.ini
deleted file mode 100644
index 9cb7df328..000000000
--- a/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston/weston-intel.ini
+++ /dev/null
@@ -1,21 +0,0 @@
-[core]
-# shell=desktop-shell.so
-backend=drm-backend.so
-shell=ivi-shell.so
-
-[ivi-shell]
-ivi-module=ivi-controller.so
-ivi-input-module=ivi-input-controller.so
-
-[shell]
-locking=true
-# Uncomment below to hide panel
-#panel-location=none
-
-[output]
-name=HDMI-A-1
-transform=90
-
-#[output]
-#name=HDMI1
-#transform=90
diff --git a/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston_%.bbappend
deleted file mode 100644
index 19e634735..000000000
--- a/meta-agl-bsp/meta-intel/recipes-graphics/wayland/weston_%.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
-SRC_URI_append = "\
- file://weston-intel.ini \
- "
-
-do_install_append() {
- WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
- install -d ${D}${WESTON_INI_CONFIG}
- install -m 0644 ${WORKDIR}/weston-intel.ini ${D}${WESTON_INI_CONFIG}/weston.ini
-}
-
-FILES_${PN} += " \
- ${sysconfdir}/xdg/weston/weston.ini \
- "
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston-qcom.ini b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston-qcom.ini
deleted file mode 100644
index 30eccc3d9..000000000
--- a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston-qcom.ini
+++ /dev/null
@@ -1,13 +0,0 @@
-[core]
-backend=drm-backend.so
-shell=ivi-shell.so
-
-[ivi-shell]
-ivi-module=ivi-controller.so
-ivi-input-module=ivi-input-controller.so
-
-[output]
-name=HDMI-A-1
-transform=270
-# Uncomment for 1080p on GeChic 1502i:
-#mode=173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
index 8fff1dfe7..f8c0a5fa3 100644
--- a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
@@ -1,20 +1,14 @@
FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
- file://weston-qcom.ini \
file://weston.sh \
"
do_install_append() {
- WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
- install -d ${D}${WESTON_INI_CONFIG}
- install -m 0644 ${WORKDIR}/weston-qcom.ini ${D}${WESTON_INI_CONFIG}/weston.ini
-
install -d ${D}/${sysconfdir}/profile.d
install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
}
FILES_${PN} += " \
- ${sysconfdir}/xdg/weston/weston.ini \
${sysconfdir}/profile.d/weston.sh \
"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
new file mode 100644
index 000000000..14b858d45
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -0,0 +1,4 @@
+# Disable LVDS
+WESTONOUTPUT2[agl_screen] ??= "SCREEN_DSI"
+
+WESTONSECTION[WESTONOUTPUT2] = "output"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini
deleted file mode 100644
index 15721e3dc..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston/weston-raspberrypi.ini
+++ /dev/null
@@ -1,19 +0,0 @@
-[core]
-backend=drm-backend.so
-shell=ivi-shell.so
-
-[ivi-shell]
-ivi-module=ivi-controller.so
-ivi-input-module=ivi-input-controller.so
-
-# HDMI / GeChic
-[output]
-name=HDMI-A-1
-transform=270
-# Uncomment for 1080p on GeChic 1502i:
-#mode=173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
-
-# official touchscreen over DSI interface
-[output]
-name=DSI-1
-transform=270
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
index 7c8167961..f8c0a5fa3 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-graphics/wayland/weston_%.bbappend
@@ -1,20 +1,14 @@
FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
- file://weston-raspberrypi.ini \
file://weston.sh \
"
do_install_append() {
- WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
- install -d ${D}${WESTON_INI_CONFIG}
- install -m 0644 ${WORKDIR}/weston-raspberrypi.ini ${D}${WESTON_INI_CONFIG}/weston.ini
-
install -d ${D}/${sysconfdir}/profile.d
install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
}
FILES_${PN} += " \
- ${sysconfdir}/xdg/weston/weston.ini \
${sysconfdir}/profile.d/weston.sh \
"
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
new file mode 100644
index 000000000..de8d9552c
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -0,0 +1 @@
+WESTONCORE[repaint-window] ??= "34"
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston/weston-rcar.ini b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston/weston-rcar.ini
deleted file mode 100644
index a37895c9c..000000000
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston/weston-rcar.ini
+++ /dev/null
@@ -1,11 +0,0 @@
-[core]
-shell=ivi-shell.so
-backend=drm-backend.so
-repaint-window=34
-
-[ivi-shell]
-ivi-module=ivi-controller.so
-
-[output]
-name=HDMI-A-1
-transform=90
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
index 98b973caa..079ff496a 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
@@ -1,15 +1,3 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
-SRC_URI_append = "\
- file://weston-rcar.ini \
- "
-
-do_install_append() {
- WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
- install -d ${D}${WESTON_INI_CONFIG}
- install -m 0644 ${WORKDIR}/weston-rcar.ini ${D}${WESTON_INI_CONFIG}/weston.ini
-}
-
FILES_${PN}_append_rcar-gen3 = " \
${libexecdir}/weston-screenshooter \
${libexecdir}/weston-ivi-shell-user-interface \
@@ -17,7 +5,3 @@ FILES_${PN}_append_rcar-gen3 = " \
${libexecdir}/weston-simple-im \
${libexecdir}/weston-desktop-shell \
"
-
-FILES_${PN}_append = " \
- ${sysconfdir}/xdg/weston/weston.ini \
- "
diff --git a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend
new file mode 100644
index 000000000..7a54dfbe4
--- /dev/null
+++ b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -0,0 +1,5 @@
+# Disable LVDS
+WESTONOUTPUT2[name] = "LVDS-1"
+WESTONOUTPUT2[mode] = "off"
+
+WESTONSECTION[WESTONOUTPUT2] = "output"
diff --git a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini
deleted file mode 100644
index 6e1c624c3..000000000
--- a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston/weston-renesas.ini
+++ /dev/null
@@ -1,20 +0,0 @@
-[core]
-backend=drm-backend.so
-shell=ivi-shell.so
-
-[ivi-shell]
-ivi-module=ivi-controller.so
-ivi-input-module=ivi-input-controller.so
-
-[output]
-name=HDMI-A-1
-transform=270
-#mode=173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
-#mode=1920x1080
-#mode=1024x768
-#transform=90
-
-[output]
-# Disable LVDS
-name=LVDS-1
-mode=off
diff --git a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend
deleted file mode 100644
index 842c380a0..000000000
--- a/meta-agl-bsp/meta-renesas/recipes-graphics/wayland/weston_%.bbappend
+++ /dev/null
@@ -1,15 +0,0 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
-SRC_URI_append = "\
- file://weston-renesas.ini \
- "
-
-do_install_append() {
- WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
- install -d ${D}${WESTON_INI_CONFIG}
- install -m 0644 ${WORKDIR}/weston-renesas.ini ${D}${WESTON_INI_CONFIG}/weston.ini
-}
-
-FILES_${PN} += " \
- ${sysconfdir}/xdg/weston/weston.ini \
- "
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/dra7xx-evm/weston.ini b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/dra7xx-evm/weston.ini
deleted file mode 100644
index da2b61dcc..000000000
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston/dra7xx-evm/weston.ini
+++ /dev/null
@@ -1,11 +0,0 @@
-[core]
-backend=drm-backend.so
-shell=ivi-shell.so
-
-[ivi-shell]
-ivi-module=ivi-controller.so
-ivi-input-module=ivi-input-controller.so
-
-[output]
-name=Unknown-1
-transform=270
diff --git a/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf.bbappend
new file mode 100644
index 000000000..dba2ad6b2
--- /dev/null
+++ b/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -0,0 +1,17 @@
+# OVERRIDES save us some c'n'p below ...
+OVERRIDES_prepend_qemux86 = "customwestonini:"
+OVERRIDES_prepend_qemux86-64 = "customwestonini:"
+# intel-corei7-64 ??
+
+python() {
+ if "customwestonini" in d.getVar("OVERRIDES", True).split(":"):
+ # DRM backend disabled for now to allow compatibility with VirtualBox
+ # and VMWare Player. It may be re-enabled if running on QEMU for
+ # potentially increased performance.
+ #backend=drm-backend.so
+ d.delVarFlag("WESTONCORE", "backend")
+
+ d.setVarFlag("WESTONOUTPUT1","agl_screen", "SCREEN_QEMU")
+}
+
+
diff --git a/meta-agl-bsp/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/recipes-graphics/wayland/weston_%.bbappend
index b117ada46..9aaea5f69 100644
--- a/meta-agl-bsp/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl-bsp/recipes-graphics/wayland/weston_%.bbappend
@@ -1,24 +1,3 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
RDEPENDS_${PN}_append_qemux86 = " mesa-megadriver"
RDEPENDS_${PN}_append_qemux86-64 = " mesa-megadriver"
RDEPENDS_${PN}_append_intel-corei7-64 = " mesa-megadriver"
-
-# OVERRIDES save us some c'n'p below ...
-OVERRIDES_prepend_qemux86 = "customwestonini:"
-OVERRIDES_prepend_qemux86-64 = "customwestonini:"
-# intel-corei7-64 ??
-
-SRC_URI_append_customwestonini = "\
- file://weston-qemu-drm.ini \
- "
-
-do_install_append_customwestonini() {
- WESTON_CONFIG_DIR=${sysconfdir}/xdg/weston
- install -d ${D}${WESTON_CONFIG_DIR}
- install -m 0644 ${WORKDIR}/weston-qemu-drm.ini ${D}${WESTON_CONFIG_DIR}/weston.ini
-}
-
-FILES_${PN}_append_customwestonini = " \
- ${sysconfdir}/xdg/weston/weston.ini \
- "
diff --git a/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb b/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb
index c92c60f90..c3863cb43 100644
--- a/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb
+++ b/meta-agl/recipes-graphics/packagegroups/packagegroup-agl-image-weston.bb
@@ -9,7 +9,7 @@ PACKAGES = "\
ALLOW_EMPTY_${PN} = "1"
-RDEPENDS_${PN} += "weston weston-examples"
+RDEPENDS_${PN} += "weston weston-ini-conf weston-examples"
RDEPENDS_${PN} += "\
packagegroup-agl-image-minimal \
diff --git a/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf b/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf
new file mode 100644
index 000000000..740ac56d1
--- /dev/null
+++ b/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf
@@ -0,0 +1,36 @@
+#Generate a weston.ini file:
+
+To generate the weston.ini file:
+
+'''
+[core]
+backend=desktop-shell.so
+shell=ivi-shell.so
+'''
+
+Just create a Variable Flag:
+
+'''
+WESTONCORE[backend]??="drm-backend.so"
+WESTONCORE[shell]??="desktop-shell.so"
+'''
+
+And add it to the Variable Flag WESTONSECTION, with the name of the section:
+'''
+WESTONSECTION[WESTONCORE]?="core"
+'''
+
+#You can custumize weston.ini by create a weston-ini-conf.bbappend:
+
+'''
+WESTONCORE[repaint-window] ??= "34"
+'''
+
+This will generate weston.ini file:
+
+'''
+[core]
+backend=desktop-shell.so
+shell=ivi-shell.so
+repaint-window=34
+'''
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb
new file mode 100644
index 000000000..01f2c6534
--- /dev/null
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb
@@ -0,0 +1,57 @@
+SUMMARY = "Startup script and systemd unit file for the Weston Wayland compositor"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
+
+S = "${WORKDIR}"
+
+require weston-ini-conf/screen.inc
+
+DEFAULT_SCREEN[transform]?="90"
+DEFAULT_SCREEN[name]?="HDMI-A-1"
+
+WESTONCORE[shell]??="desktop-shell.so"
+WESTONCORE[backend]??="drm-backend.so"
+
+WESTONSHELL[locking]="true"
+# Uncomment below to hide panel
+#WESTONSHELL[panel-location]="none"
+
+WESTONOUTPUT1[agl_screen]??="DEFAULT_SCREEN"
+
+WESTONSECTION[WESTONCORE]?="core"
+WESTONSECTION[WESTONSHELL]?="shell"
+WESTONSECTION[WESTONOUTPUT1]?="output"
+
+python do_generate_weston_init() {
+ with open(d.getVar('WORKDIR', True)+"/weston.ini" ,'w') as weston_ini:
+ dicoSection=d.getVarFlags('WESTONSECTION')
+ keysSection=list(dicoSection.keys())
+ keysSection.sort()
+ for section in keysSection:
+ weston_ini.writelines( "["+dicoSection[section]+"]\n")
+ dicoSectionValues=d.getVarFlags(section)
+ keysSectionValues=list(dicoSectionValues.keys())
+ keysSectionValues.sort()
+ for sectionValue in keysSectionValues:
+ if (dicoSection[section] == "output" and sectionValue == "agl_screen"):
+ screen=dicoSectionValues[sectionValue]
+ dicoScreenConfig=d.getVarFlags(screen)
+ keysScreenConfig=list(dicoScreenConfig.keys())
+ keysScreenConfig.sort()
+ for screenConfig in keysScreenConfig:
+ weston_ini.writelines( screenConfig+"="+dicoScreenConfig[screenConfig]+"\n")
+ else:
+ weston_ini.writelines( str(sectionValue)+"="+str(dicoSectionValues[sectionValue])+"\n")
+
+ weston_ini.writelines( "\n")
+}
+
+#ar_src = d.getVarFlag('ARCHIVER_MODE', 'src', True)
+
+addtask do_generate_weston_init after do_compile before do_install
+
+do_install_append() {
+ WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+ install -d ${D}${WESTON_INI_CONFIG}
+ install -m 0644 ${WORKDIR}/weston.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+}
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen.inc b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen.inc
new file mode 100644
index 000000000..1c7718c70
--- /dev/null
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen.inc
@@ -0,0 +1,4 @@
+require screen_dell.inc
+require screen_qemu.inc
+require screen_GeChic.inc
+require screen_DSI.inc
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_DSI.inc b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_DSI.inc
new file mode 100644
index 000000000..d5d91bf68
--- /dev/null
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_DSI.inc
@@ -0,0 +1,2 @@
+SCREEN_DSI[name] ?= "DSI-1"
+SCREEN_DSI[transform] ?= "270"
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_GeChic.inc b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_GeChic.inc
new file mode 100644
index 000000000..d82b18027
--- /dev/null
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_GeChic.inc
@@ -0,0 +1,4 @@
+SCREEN_GECHIC[name] ?= "HDMI-A-1"
+SCREEN_GECHIC[transform] ?= "270"
+# for 1080p on GeChic 1502i:
+SCREEN_GECHIC[mode] = "173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync"
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_dell.inc b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_dell.inc
new file mode 100644
index 000000000..051e2ee0d
--- /dev/null
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_dell.inc
@@ -0,0 +1,2 @@
+SCREEN_DELL[name]?="HDMI-A-1"
+SCREEN_DELL[transform]?="180"
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_qemu.inc b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_qemu.inc
new file mode 100644
index 000000000..76dd8b81f
--- /dev/null
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_qemu.inc
@@ -0,0 +1,16 @@
+SCREEN_QEMU[name]?="Virtual-1"
+#mode=1920x1080
+#mode=1600x1200
+#mode=1680x1050
+#mode=1400x1050
+SCREEN_QEMU[mode]?="1600x900"
+#mode=1280x1024
+#mode=1440x900
+#mode=1280x960
+#mode=1360x768
+#mode=1280x800
+#mode=1280x768
+#mode=1280x720
+#mode=800x600
+#mode=848x480
+#mode=640x480
diff --git a/meta-agl/recipes-graphics/wayland/weston/weston.ini b/meta-agl/recipes-graphics/wayland/weston/weston.ini
deleted file mode 100644
index b533d8908..000000000
--- a/meta-agl/recipes-graphics/wayland/weston/weston.ini
+++ /dev/null
@@ -1,7 +0,0 @@
-[core]
-shell=desktop-shell.so
-
-[shell]
-locking=true
-# Uncomment below to hide panel
-#panel-location=none
diff --git a/meta-agl/recipes-graphics/wayland/weston_%.bbappend b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
index 95b886c6e..217c4fc0b 100644
--- a/meta-agl/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
@@ -3,7 +3,6 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
file://0001-compositor-drm.c-Launch-without-input-devices.patch \
file://weston.service \
- file://weston.ini \
"
inherit systemd
@@ -16,12 +15,4 @@ do_install_append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -m 644 -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
fi
-
- WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
- install -d ${D}${WESTON_INI_CONFIG}
- install -m 0644 ${WORKDIR}/weston.ini ${D}${WESTON_INI_CONFIG}/weston.ini
}
-
-FILES_${PN} += " \
- ${sysconfdir}/xdg/weston/weston.ini \
- "
diff --git a/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-graphics.bb b/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-graphics.bb
index 01a7e0dc3..5021caa3a 100644
--- a/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-graphics.bb
+++ b/meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-graphics.bb
@@ -12,6 +12,6 @@ PACKAGES = "\
ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "\
- weston weston-examples \
+ weston weston-ini-conf weston-examples \
wayland-ivi-extension \
"
diff --git a/meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell-config.bb b/meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell-config.bb
deleted file mode 100644
index 08921ef8e..000000000
--- a/meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell-config.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "Configuration file for Weston IVI-Shell"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
-
-FILESEXTRAPATHS_prepend := ":${THISDIR}/weston-ivi-shell:"
-
-SRC_URI = "file://weston.ini.ivi-shell"
-
-do_install() {
- install -d ${D}${sysconfdir}/xdg/weston
- install -m644 ${WORKDIR}/weston.ini.ivi-shell ${D}${sysconfdir}/xdg/weston/weston.ini
-}
-
-RDEPENDS_${PN} = "weston"
diff --git a/meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell/weston.ini.ivi-shell b/meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell/weston.ini.ivi-shell
deleted file mode 100644
index 982ab8789..000000000
--- a/meta-ivi-common/recipes-graphics/wayland/weston-ivi-shell/weston.ini.ivi-shell
+++ /dev/null
@@ -1,99 +0,0 @@
-[core]
-shell=ivi-shell.so
-
-[ivi-shell]
-ivi-module=hmi-controller.so
-#ivi-module=hmi-controller.so,ivi-controller.so
-ivi-shell-user-interface=/usr/lib/weston/weston-ivi-shell-user-interface
-
-#developermode=true
-
-cursor-theme=default
-cursor-size=32
-
-base-layer-id=1000
-workspace-background-layer-id=2000
-workspace-layer-id=3000
-application-layer-id=4000
-
-transition-duration=300
-
-background-icon=/usr/share/weston/background.png
-background-id=1001
-panel-icon=/usr/share/weston/panel.png
-panel-id=1002
-tiling-icon=/usr/share/weston/tiling.png
-tiling-id=1003
-sidebyside-icon=/usr/share/weston/sidebyside.png
-sidebyside-id=1004
-fullscreen-icon=/usr/share/weston/fullscreen.png
-fullscreen-id=1005
-random-icon=/usr/share/weston/random.png
-random-id=1006
-home-icon=/usr/share/weston/home.png
-home-id=1007
-workspace-background-color=0x99000000
-workspace-background-id=2001
-
-[input-method]
-path=/usr/lib/weston/weston-keyboard
-
-[ivi-launcher]
-workspace-id=0
-icon-id=4001
-icon=/usr/share/weston/icon_ivi_flower.png
-path=/usr/bin/weston-flower
-
-[ivi-launcher]
-workspace-id=0
-icon-id=4002
-icon=/usr/share/weston/icon_ivi_clickdot.png
-path=/usr/bin/weston-clickdot
-
-[ivi-launcher]
-workspace-id=1
-icon-id=4003
-icon=/usr/share/weston/icon_ivi_simple-egl.png
-path=/usr/bin/weston-simple-egl
-
-[ivi-launcher]
-workspace-id=1
-icon-id=4004
-icon=/usr/share/weston/icon_ivi_simple-shm.png
-path=/usr/bin/weston-simple-shm
-
-[ivi-launcher]
-workspace-id=2
-icon-id=4005
-icon=/usr/share/weston/icon_ivi_smoke.png
-path=/usr/bin/weston-smoke
-
-[ivi-launcher]
-workspace-id=3
-icon-id=4006
-icon=/usr/share/weston/icon_ivi_flower.png
-path=/usr/bin/weston-flower
-
-[ivi-launcher]
-workspace-id=3
-icon-id=4007
-icon=/usr/share/weston/icon_ivi_clickdot.png
-path=/usr/bin/weston-clickdot
-
-[ivi-launcher]
-workspace-id=3
-icon-id=4008
-icon=/usr/share/weston/icon_ivi_simple-egl.png
-path=/usr/bin/weston-simple-egl
-
-[ivi-launcher]
-workspace-id=3
-icon-id=4009
-icon=/usr/share/weston/icon_ivi_simple-shm.png
-path=/usr/bin/weston-simple-shm
-
-[ivi-launcher]
-workspace-id=3
-icon-id=4010
-icon=/usr/share/weston/icon_ivi_smoke.png
-path=/usr/bin/weston-smoke