summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-07-27 18:40:45 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-07-29 23:02:27 +0000
commit8d2bcfc384c9e7464ffc77343c0b094e0e65b285 (patch)
tree439e426d36583bfe28f2a98fbf75d79a47f3263c
parent321af7331c91a174b52eb5e17d8ab5b3e72ce5cb (diff)
meta-app-framework: add Flutter app template
Add a systemd template unit for Flutter based applications to the applaunchd recipe. Bug-AGL: SPEC-4466 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia7cb24d27beebf7c7e4bcfb7a256bd45ffa432ce Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27838 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-boot-test: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-app-framework/recipes-core/applaunchd/applaunchd/agl-app-flutter@.service8
-rw-r--r--meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb8
2 files changed, 15 insertions, 1 deletions
diff --git a/meta-app-framework/recipes-core/applaunchd/applaunchd/agl-app-flutter@.service b/meta-app-framework/recipes-core/applaunchd/applaunchd/agl-app-flutter@.service
new file mode 100644
index 000000000..7802bb240
--- /dev/null
+++ b/meta-app-framework/recipes-core/applaunchd/applaunchd/agl-app-flutter@.service
@@ -0,0 +1,8 @@
+[Unit]
+Description=%I
+
+[Service]
+Type=simple
+User=agl-driver
+Environment=XDG_RUNTIME_DIR=/run/user/1001/
+ExecStart=/usr/bin/flutter --b=/usr/share/flutter/%I --app-id=%I
diff --git a/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb b/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
index 0aef4e003..e6439c3dd 100644
--- a/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
+++ b/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
@@ -17,6 +17,7 @@ SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/src/applaunchd;protocol=https;branch=${AGL_BRANCH} \
file://agl-app@.service \
file://agl-app-web@.service \
+ file://agl-app-flutter@.service \
file://no-network.conf \
file://private-tmp.conf \
"
@@ -31,6 +32,7 @@ do_install:append() {
install -d ${D}${systemd_system_unitdir}
install -m 644 ${WORKDIR}/agl-app@.service ${D}${systemd_system_unitdir}/
install -m 644 ${WORKDIR}/agl-app-web@.service ${D}${systemd_system_unitdir}/
+ install -m 644 ${WORKDIR}/agl-app-flutter@.service ${D}${systemd_system_unitdir}/
# Install individual sandboxing overrides/drop-ins to be used by apps
install -d ${D}${systemd_system_unitdir}/sandboxing
@@ -38,7 +40,7 @@ do_install:append() {
install -m 644 ${WORKDIR}/private-tmp.conf ${D}${systemd_system_unitdir}/sandboxing/
}
-PACKAGE_BEFORE_PN += "${PN}-template-agl-app ${PN}-template-agl-app-web"
+PACKAGE_BEFORE_PN += "${PN}-template-agl-app ${PN}-template-agl-app-web ${PN}-template-agl-app-flutter"
FILES:${PN} += "${systemd_system_unitdir} ${datadir}/dbus-1/"
@@ -46,6 +48,8 @@ FILES:${PN}-template-agl-app = "${systemd_system_unitdir}/agl-app@.service"
FILES:${PN}-template-agl-app-web = "${systemd_system_unitdir}/agl-app-web@.service"
+FILES:${PN}-template-agl-app-flutter = "${systemd_system_unitdir}/agl-app-flutter@.service"
+
RDEPENDS:${PN} += " \
agl-session \
polkit-rule-agl-app \
@@ -54,3 +58,5 @@ RDEPENDS:${PN} += " \
RDEPENDS:${PN}-template-agl-app = "${PN}"
RDEPENDS:${PN}-template-agl-app-web = "${PN}"
+
+RDEPENDS:${PN}-template-agl-app-flutter = "${PN}"