summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-03-06 22:32:19 +0000
committerGerrit Code Review <gerrit@automotivelinux.org>2018-03-06 22:32:19 +0000
commitb7671505e59554028aba87ca1df4d34ba9a122a4 (patch)
treef6d6845f5f955d684a2440c41858dac9a7d181de
parent1144907f57b9a57e5235ef201de2b6633d23f834 (diff)
parentc720ba115fe659868691822170a0374aaef9aeed (diff)
Merge "af-binder: Upgrade"
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb19
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc2
2 files changed, 18 insertions, 3 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
index 1850e2bd8..91f26b894 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
@@ -4,12 +4,27 @@ DEPENDS = "file json-c libmicrohttpd systemd util-linux openssl cynara"
inherit cmake pkgconfig
-EXTRA_OECMAKE_append_agl-devel = " -DAGL_DEVEL=ON -DINCLUDE_MONITORING=ON"
+EXTRA_OECMAKE_append_class-target = "\
+ -DUNITDIR_SYSTEM=${systemd_system_unitdir} \
+"
+
+EXTRA_OECMAKE_append_agl-devel = " \
+ -DAGL_DEVEL=ON \
+ -DINCLUDE_MONITORING=ON \
+ -DINCLUDE_SUPERVISOR=ON -DAFS_SURPERVISION_SOCKET=/run/platform/supervisor \
+"
pkg_postinst_${PN}() {
mkdir -p "$D${libdir}/afb"
}
+do_install_append_agl-devel_class-target() {
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ install -d -m 0755 ${D}${systemd_system_unitdir}/multi-user.target.wants
+ ln -s ../afs-supervisor.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afs-supervisor.service
+ fi
+}
+
#############################################
# setup package
#############################################
@@ -17,7 +32,7 @@ PACKAGES =+ "${PN}-tools ${PN}-devtools ${PN}-meta"
FILES_${PN} += "${datadir}"
-FILES_${PN}_append_agl-devel = " ${libdir}/afb/monitoring"
+FILES_${PN}_append_agl-devel = " ${libdir}/afb/monitoring ${systemd_system_unitdir}"
ALLOW_EMPTY_${PN}-meta = "1"
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc
index ac55b5f02..48123c0b4 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.inc
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-binder;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "9c1c9a1ba46eb9ddada4167ce9d20143ee3c9636"
+SRCREV = "bd10bc4405f3777fe495cb9f62818d67ab584854"
PV = "${AGL_BRANCH}+git${SRCPV}"
S = "${WORKDIR}/git"