summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2019-10-31 14:32:20 +0000
committerRonan Le Martret <ronan.lemartret@iot.bzh>2019-10-31 14:36:50 +0000
commitd6ea4202a437019e32b7e78604ef060e267b142d (patch)
tree29fed22813378bca903811742ec11b9e17bf8899
parent01933949c6553ccf2c58f17c55c0c72e7e22d71c (diff)
Replace tab by 4 spaces
- yocto zeus QA check tab in recipes. Replace tab by spaces is mandatory in yocto zeus. Bug-AGL: SPEC-2932 Change-Id: I7776d4e72888114ab42e5c287971e8242885fe99 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
-rw-r--r--meta-agl-profile-core/recipes-kernel/most/most.bbappend34
-rw-r--r--meta-netboot/classes/netboot.bbclass34
2 files changed, 34 insertions, 34 deletions
diff --git a/meta-agl-profile-core/recipes-kernel/most/most.bbappend b/meta-agl-profile-core/recipes-kernel/most/most.bbappend
index a90210d8f..17ad05585 100644
--- a/meta-agl-profile-core/recipes-kernel/most/most.bbappend
+++ b/meta-agl-profile-core/recipes-kernel/most/most.bbappend
@@ -1,11 +1,11 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
def prep_version (d) :
- KV = d.getVar('KERNEL_VERSION', True)
- if not KV :
- return "4.12"
- else:
- return KV
+ KV = d.getVar('KERNEL_VERSION', True)
+ if not KV :
+ return "4.12"
+ else:
+ return KV
ORIG_KERN_VER = "${@prep_version(d)}"
@@ -15,17 +15,17 @@ APPLY = "${@str('no' if ${VANILLA_KERNEL_VERSION} > 412 else 'yes')}"
APPLY_419 = "${@str('no' if ${VANILLA_KERNEL_VERSION} < 419 else 'yes')}"
SRC_URI_append = " \
- file://0001-most-aim-network-backport-Kernel-API.patch;apply=${APPLY} \
- file://0002-src-most-add-auto-conf-feature.patch \
- file://0003-core-remove-kernel-log-for-MBO-status.patch \
- file://0004-most-video-set-device_caps.patch \
- file://0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch \
- file://0006-dim2-fix-startup-sequence.patch \
- file://0007-dim2-use-device-tree.patch \
- file://0008-dim2-read-clock-speed-from-the-device-tree.patch \
- file://0009-dim2-use-device-for-coherent-memory-allocation.patch \
- file://0010-backport-usb-setup-timer.patch \
- file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch;apply=${APPLY_419} \
- "
+ file://0001-most-aim-network-backport-Kernel-API.patch;apply=${APPLY} \
+ file://0002-src-most-add-auto-conf-feature.patch \
+ file://0003-core-remove-kernel-log-for-MBO-status.patch \
+ file://0004-most-video-set-device_caps.patch \
+ file://0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch \
+ file://0006-dim2-fix-startup-sequence.patch \
+ file://0007-dim2-use-device-tree.patch \
+ file://0008-dim2-read-clock-speed-from-the-device-tree.patch \
+ file://0009-dim2-use-device-for-coherent-memory-allocation.patch \
+ file://0010-backport-usb-setup-timer.patch \
+ file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch;apply=${APPLY_419} \
+ "
# Make sure we can expose KERNEL_VERSION ...
do_patch[depends] += "virtual/kernel:do_populate_sysroot"
diff --git a/meta-netboot/classes/netboot.bbclass b/meta-netboot/classes/netboot.bbclass
index 363e6bcc9..85a0ead01 100644
--- a/meta-netboot/classes/netboot.bbclass
+++ b/meta-netboot/classes/netboot.bbclass
@@ -1,22 +1,22 @@
# Enable network bootable image and initrd/initramfs
python () {
- if (bb.utils.contains_any("IMAGE_FSTYPES",["live","wic.vmdk"],True,False,d)):
- # typical case for Minnowboard Max
- d.setVar("INITRD_IMAGE","initramfs-netboot-image")
- d.setVar("INITRD_IMAGE_LIVE",d.getVar("INITRD_IMAGE",True))
- d.setVar("INITRD_LIVE","%s/%s-%s.ext4.gz" % (
- d.getVar("DEPLOY_DIR_IMAGE",True),
- d.getVar("INITRD_IMAGE_LIVE",True),
- d.getVar("MACHINE",True)
- ))
- else:
- d.setVar("INITRAMFS_IMAGE","initramfs-netboot-image")
- if (d.getVar("KERNEL_IMAGETYPE",True) == "uImage"):
- # case for "old" u-boot images, like Porter board
- d.setVar("NETBOOT_FSTYPES", "ext4.gz.u-boot");
- else:
- # case for new u-boot images which don't require uImage format
- d.setVar("NETBOOT_FSTYPES", "ext4.gz");
+ if (bb.utils.contains_any("IMAGE_FSTYPES",["live","wic.vmdk"],True,False,d)):
+ # typical case for Minnowboard Max
+ d.setVar("INITRD_IMAGE","initramfs-netboot-image")
+ d.setVar("INITRD_IMAGE_LIVE",d.getVar("INITRD_IMAGE",True))
+ d.setVar("INITRD_LIVE","%s/%s-%s.ext4.gz" % (
+ d.getVar("DEPLOY_DIR_IMAGE",True),
+ d.getVar("INITRD_IMAGE_LIVE",True),
+ d.getVar("MACHINE",True)
+ ))
+ else:
+ d.setVar("INITRAMFS_IMAGE","initramfs-netboot-image")
+ if (d.getVar("KERNEL_IMAGETYPE",True) == "uImage"):
+ # case for "old" u-boot images, like Porter board
+ d.setVar("NETBOOT_FSTYPES", "ext4.gz.u-boot");
+ else:
+ # case for new u-boot images which don't require uImage format
+ d.setVar("NETBOOT_FSTYPES", "ext4.gz");
}