summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2017-10-13 23:00:50 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-14 15:24:59 +0000
commite336a5bd49d492bdff10f99311f832007b5c25e6 (patch)
tree99bdf155fff3ee24df6481a03efd08c49ac53b6e
parentf1d3961d6c86983fab125897c2db8892100d2c12 (diff)
weston: Set require-input to false in weston.ini
Revert the previous fix for launching Weston 2.0 without input devices and achieve the same result by setting the directive require-input to false in the configuration file weston.ini. This is a new feature which has been introduced in Weston since version 2.0. Bug-AGL: SPEC-936 Change-Id: I65ccc0d9942d86420cd801f571ccbefe58812796 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11301 Reviewed-by: Matt Ranostay <matt.ranostay@konsulko.com> Reviewed-by: José Bollo <jobol@nonadev.net> Reviewed-by: Thomas Rini <trini@konsulko.com> Reviewed-by: Matt Porter <mporter@konsulko.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf.bb1
-rw-r--r--meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch27
-rw-r--r--meta-agl/recipes-graphics/wayland/weston_2.0.0.bbappend1
3 files changed, 1 insertions, 28 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb
index c7eee62ce..0edc05d24 100644
--- a/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb
@@ -11,6 +11,7 @@ DEFAULT_SCREEN[name]?="HDMI-A-1"
WESTONCORE[shell]??="desktop-shell.so"
WESTONCORE[backend]??="drm-backend.so"
+WESTONCORE[require-input]??="false"
WESTONSHELL[locking]="true"
# hide panel
diff --git a/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch b/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch
deleted file mode 100644
index 6b47b5e89..000000000
--- a/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 9da4f513547b4a4f0972cc718b55ba3fc5271c87 Mon Sep 17 00:00:00 2001
-From: Leon Anavi <leon.anavi@konsulko.com>
-Date: Tue, 10 Oct 2017 17:21:09 +0300
-Subject: [PATCH] compositor-drm.c: Launch without input devices
-
-Launch Weston 2.0 even if there are no input devices.
-
-Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
----
- libweston/compositor-drm.c | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/libweston/compositor-drm.c b/libweston/compositor-drm.c
-index 1d38f05..afe0dea 100644
---- a/libweston/compositor-drm.c
-+++ b/libweston/compositor-drm.c
-@@ -3278,7 +3278,6 @@ drm_backend_create(struct weston_compositor *compositor,
- compositor, b->udev, seat_id,
- config->configure_device) < 0) {
- weston_log("failed to create input devices\n");
-- goto err_sprite;
- }
-
- b->connector = config->connector;
---
-2.7.4
-
diff --git a/meta-agl/recipes-graphics/wayland/weston_2.0.0.bbappend b/meta-agl/recipes-graphics/wayland/weston_2.0.0.bbappend
index 32df379b3..65f34bc24 100644
--- a/meta-agl/recipes-graphics/wayland/weston_2.0.0.bbappend
+++ b/meta-agl/recipes-graphics/wayland/weston_2.0.0.bbappend
@@ -2,7 +2,6 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
file://0001-Allow-regular-users-to-launch-Weston_2.0.0.patch \
- file://0001-compositor-drm.c-Launch-without-input-devices.patch \
"
EXTRA_OECONF_append = " --enable-sys-uid"