summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHiroyuki Ishii <ishii.hiroyuki002@jp.panasonic.com>2021-09-09 10:43:22 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-09-22 15:32:44 +0000
commitfab29403e0da3ff8ee6c9fef76e115aa53a06ff7 (patch)
tree5a1875216133842c782eda59417f5463cb5f8b86
parent2800bb4dca20d794457d0f39495129b0ee0e8fc0 (diff)
raspberrypi: Upgrade to u-boot v2021.07 for latest 4B boards
The latest revision (1.4) of raspberry pi 4B board can't be boot by using current version of u-boot with showing "No partition table" message. This can be related to the change of DMA hardware on the new SoC (2711ZPKFSB06C0T) and we've confirmed upgrading u-boot to newer version than 2021.04 which has several fixes around Broadcom's DMA solves the issue. Also, we'd like to choice 2021.07 rather than 2021.04 since it's going to be supported for longer in yocto project. Bug-AGL: SPEC-4072 Signed-off-by: Hiroyuki Ishii <ishii.hiroyuki002@jp.panasonic.com> Change-Id: I7cbca889a93909e15ab04263c6d7d635a839bd56 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26624 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-by: Scott Murray <scott.murray@konsulko.com>
-rw-r--r--meta-agl-bsp/conf/include/agl_raspberrypi4.inc4
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2021.07.inc3
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2021.07.bb2
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2021.07.bb2
4 files changed, 9 insertions, 2 deletions
diff --git a/meta-agl-bsp/conf/include/agl_raspberrypi4.inc b/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
index 09cdfa7c1..5a0e89e66 100644
--- a/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
+++ b/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
@@ -30,6 +30,6 @@ IMAGE_INSTALL:append = " ${@bb.utils.contains('AGL_XEN_WANTED', '1', 'xen-tools
# Add xen-raspberry binary to boot files
IMAGE_BOOT_FILES:append = " ${@bb.utils.contains('AGL_XEN_WANTED','1', 'xen-${MACHINE}', '',d)}"
-PREFERRED_VERSION_u-boot = "2020.10"
-PREFERRED_VERSION_u-boot-tools = "2020.10"
+PREFERRED_VERSION_u-boot = "2021.07"
+PREFERRED_VERSION_u-boot-tools = "2021.07"
UBOOT_MACHINE:rpi = "rpi_arm64_config"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2021.07.inc b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2021.07.inc
new file mode 100644
index 000000000..abf7474c9
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-2021.07.inc
@@ -0,0 +1,3 @@
+SRC_URI = "git://git.denx.de/u-boot.git"
+SRCREV = "840658b093976390e9537724f802281c9c8439f5"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=5a7450c57ffe5ae63fd732446b988025"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2021.07.bb b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2021.07.bb
new file mode 100644
index 000000000..a963d3fff
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot-tools_2021.07.bb
@@ -0,0 +1,2 @@
+require recipes-bsp/u-boot/u-boot-tools_2020.01.bb
+require u-boot-2021.07.inc
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2021.07.bb b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2021.07.bb
new file mode 100644
index 000000000..2077262a3
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2021.07.bb
@@ -0,0 +1,2 @@
+require recipes-bsp/u-boot/u-boot_2020.01.bb
+require u-boot-2021.07.inc