summaryrefslogtreecommitdiffstats
path: root/docs
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-05-15 14:46:21 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-05-31 18:16:00 +0200
commitb43165328658087277b667152fdbc04fe07cba08 (patch)
treed1540adb65af28e41e9ebdfdbfe8b08470cb6887 /docs
parentc40ee88f6aa0b379787a9ea3c853a806892e0dd1 (diff)
3rd part of the layer/profile rework [1/2]
This is the last larger commit in this series and deals with the graphical part. We introduce the graphical profiles: - meta-agl-profile-graphical -- meta-agl-profile-graphical-html5 -- meta-agl-profile-graphical-qt5 Notable changes: - weston-ini-conf moved to the meta-agl-bsp layer. Most BSPs have bbappends, so we need to have the recipes present (but unused) even in the console images. - new image: agl-image-boot = terminal-only + network + package-manaager. Ready for using package-feeds - new image/sdk: agl-image-minimal-crosssdk - agl-service-mediaplayer has a dependency on weston, thus it cannot be in the 'core'. Moved it to profile-graphical. - The wayland-ivi-extension moved to the agl-demo-platform. - The app-framework layer included and pulled 'web-runtime' as dependency. This broke console-only images. This has been moved to be in meta-agl-demo only for now. - added and massaged the agl-features. - found and added a useful script 'oe-depends-dot' that helps to work with the dot files (produced with bitbake -g) Todo: - we'll need another pass through the packagegroups. The dependencies for the layers/profiles are now sorted-out but we might have to add/shuffle a few packages. For further details, see meta-agl/docs/profiles.md. v2: fix meta-agl/meta-security/conf/layer.conf - the immediate expansion previously used in there caused some recipes not being added to BBFILES. v3: fix packagegroup renaming (packagegroup-agl-devel -> packagegroup-agl-core-devel) v4: fix missing packagegroup inclusion (tnx Jose, Scott, Stephane) v5: fix missing packagegroup inclusion v6: explicitely put profile-graphical-qt5 on-top of profile-graphical v7: re-add 'procps' when agl-devel feature is on Bug-AGL: SPEC-145 Change-Id: I24cdcd1118932758d0c55d333338238f2a770877 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'docs')
-rw-r--r--docs/profiles.md134
1 files changed, 134 insertions, 0 deletions
diff --git a/docs/profiles.md b/docs/profiles.md
new file mode 100644
index 000000000..6c7e76730
--- /dev/null
+++ b/docs/profiles.md
@@ -0,0 +1,134 @@
+# AGL Profiles
+
+The AGL Profiles cover the different use-cases that the AGL platform serves. This ranges from minimal systems without display, telematic systems, HUD, IVI, ADAS and more. Common to all of them is the use of the AGL APIs (agl-service-*).
+
+All systems have the 'core' profile in common. This small set of libraries and binaries is the essential set including the AGL APIs that every AGL system needs. All other profiles reuse the 'core' profile.
+
+The other profiles and their dependencies are currently:
+
+ * agl-profile-core
+ * agl-profile-telematics
+ * agl-profile-hud
+ * agl-profile-graphical
+ * agl-profile-graphical-html5
+ * agl-profile-graphical-qt5
+ * agl-demo-platform
+
+
+
+## agl-profile-core
+This profile contains the following images:
+* agl-image-boot
+ * agl-image-minimal
+ * agl-image-minimal-crosssdk
+
+### agl-image-boot
+This image is only meant to boot the target device and provide network, package-management and a shell.
+All other functionality needs to be installed at runtime through 'dnf' using the provided package feeds and package-groups (e.g. dnf install profile-graphical-qt5)
+
+### agl-image-minimal
+This is the smallest image that includes all (non-graphical) AGL APIs.
+
+### agl-image-minimal-crosssdk
+This is the SDK for systems without display including the AGL APIs.
+
+## agl-profile-telematics
+N.N.
+
+## agl-profile-hud
+N.N.
+
+## agl-profile-graphical
+This profile contains a basic graphical system with wayland/weston. It is used as a base for the more targeted profiles:
+* agl-profile-graphical-html5
+* agl-profile-graphical-qt5
+
+Part of this layer are the following images:
+* agl-image-weston
+
+### agl-image-weston
+Pure wayland + weston image but with all AGL service APIs.
+
+## agl-profile-graphical-html5
+This profile contains all components to build a html5 / web-based system and should be used as a base layer for further projects.
+All AGL APIs are included.
+
+## agl-profile-graphical-qt5
+This profile is used as base for all projects that build on qt5 like the agl-demo-platform.
+Part of this layer are the ffollowing images:
+* agl-image-graphical-qt5
+* agl-image-graphical-qt5-crosssdk (THIS IS THE SDK TARGET WE AIM TO USE FOR AGL-DEMO-PLATFORM IN THE END)
+
+All AGL APIs are included.
+
+
+All AGL APIs are included.
+
+### agl-image-graphical-qt5
+Image with wayland/weston and the qt5 packages installed.
+
+### agl-image-graphical-qt5-crosssdk
+SDK based on agl-image-graphical-qt5 suitable for development under qt5.
+
+
+
+## agl-demo-platform
+This layer builds on-top of agl-profile-graphical-qt5 and builds the full AGL demonstrator image.
+It hosts these images:
+* agl-demo-platform
+* agl-demo-platform-crosssdk
+* agl-demo-platform-qa
+
+
+
+
+TLDR:
+
+```
+meta-agl/meta-agl-profile-core/recipes-platform
+|-- images
+| |-- agl-image-boot.bb
+| |-- agl-image-boot.inc
+| |-- agl-image-minimal-crosssdk.bb
+| |-- agl-image-minimal-qa.bb
+| |-- agl-image-minimal.bb
+| `-- agl-image-minimal.inc
+`-- packagegroups
+ |-- packagegroup-agl-core-boot.bb
+ |-- packagegroup-agl-core-connectivity.bb
+ |-- packagegroup-agl-core-multimedia.bb
+ |-- packagegroup-agl-core-navigation.bb
+ |-- packagegroup-agl-core-os-commonlibs.bb
+ |-- packagegroup-agl-core-security.bb
+ |-- packagegroup-agl-core-services.bb
+ |-- packagegroup-agl-image-boot.bb
+ `-- packagegroup-agl-image-minimal.bb
+
+ meta-agl/meta-agl-profile-graphical/recipes-platform
+|-- images
+| |-- agl-image-weston.bb
+| `-- agl-image-weston.inc
+`-- packagegroups
+ |-- packagegroup-agl-graphical-services.bb
+ `-- packagegroup-agl-image-weston.bb
+
+ meta-agl/meta-agl-profile-graphical-html5/recipes-platform
+|-- images
+| |-- agl-demo-platform-html5-crosssdk.bb
+| |-- agl-demo-platform-html5.bb
+| `-- agl-demo-platform-html5.inc
+`-- packagegroups
+ `-- packagegroup-agl-demo-platform-html5.bb
+
+ meta-agl/meta-agl-profile-graphical-qt5/recipes-platform
+|-- images
+| |-- agl-image-graphical-qt5-crosssdk.bb
+| |-- agl-image-graphical-qt5.bb
+| `-- agl-image-graphical-qt5.inc
+`-- packagegroups
+ |-- packagegroup-agl-appfw-native-qt5.bb
+ |-- packagegroup-agl-demo-qt-examples.bb
+ |-- packagegroup-agl-profile-graphical-qt5.bb
+ `-- packagegroup-qt5-toolchain-target.bbappend
+```
+