summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/conf/include
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-20 18:35:25 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-26 16:48:20 +0000
commitad4b257624ee9827dac00f108fb65978157f06ac (patch)
tree8fe93ac708814f317d2d4974286e64db312af87f /meta-agl-bsp/conf/include
parent34105bf54189a6ed9cb86f60550623a72f1bd8c2 (diff)
Allow -nogfx boards to start the homescreen
This allows to produce working images without restricted licenses. Software rendering will be slow and screen updates take a while. v2: adapted to use WESTON_USE_PIXMAN Bug-AGL: SPEC-3774 Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: Iaea1985da48985dfe223471a86b04d8921cc8d7a Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25933 Reviewed-by: Scott Murray <scott.murray@konsulko.com> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Diffstat (limited to 'meta-agl-bsp/conf/include')
-rw-r--r--meta-agl-bsp/conf/include/agl_h3-salvator-x-nogfx.inc4
-rw-r--r--meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc4
-rw-r--r--meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc4
3 files changed, 12 insertions, 0 deletions
diff --git a/meta-agl-bsp/conf/include/agl_h3-salvator-x-nogfx.inc b/meta-agl-bsp/conf/include/agl_h3-salvator-x-nogfx.inc
index c12026351..3bc9f95c2 100644
--- a/meta-agl-bsp/conf/include/agl_h3-salvator-x-nogfx.inc
+++ b/meta-agl-bsp/conf/include/agl_h3-salvator-x-nogfx.inc
@@ -8,3 +8,7 @@ DTB_SUFFIX = "r8a7795-salvator-xs"
BBMASK += "gles-user-module|kernel-module-gles|wayland-kms|libgbm"
# Mask MMP recipes
BBMASK += "kernel-module-uvcs-drv|omx-user-module"
+
+# do use software rendering to display the compositor
+# used for images w/o binary-only driver
+WESTON_USE_PIXMAN = "1"
diff --git a/meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc b/meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc
index 70bc68b2e..25dfb046d 100644
--- a/meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc
+++ b/meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc
@@ -11,3 +11,7 @@ BBMASK += "kernel-module-uvcs-drv|omx-user-module"
# Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
+
+# do use software rendering to display the compositor
+# used for images w/o binary-only driver
+WESTON_USE_PIXMAN = "1"
diff --git a/meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc b/meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc
index 28360fcc9..48fe12eaf 100644
--- a/meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc
+++ b/meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc
@@ -14,3 +14,7 @@ IMAGE_INSTALL_append = "${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen-base x
# Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
+
+# do use software rendering to display the compositor
+# used for images w/o binary-only driver
+WESTON_USE_PIXMAN = "1"