summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-qcom
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-04-12 14:07:33 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-04-19 11:18:50 +0000
commit029de35a172da31b083b86d93a79d787773dec11 (patch)
treed49ead563efec4f599900dd4abfca4c4dd14476a /meta-agl-bsp/meta-qcom
parent473b4354758ea6657fd196c30fb14332b5e7178d (diff)
Use weston-init to startup weston
* weston.service should not be a part of weston recipes * remove weston.service from AGL weston recipes * yocto upstream uses the recipe weston-init to startup weston * customize weston-start with sed - remove openvt - add option to weston-launch * customize weston.service with sed - add option for weston * unified the weston startup beteween AGL BSPs * remove fix on the AGL BSP Bug-AGL: SPEC-452 Bug-AGL: SPEC-310 Change-Id: I12722826abdc004214d289961e900c36528ec6e3 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl-bsp/meta-qcom')
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh7
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend14
2 files changed, 0 insertions, 21 deletions
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh
deleted file mode 100644
index 225a034bb..000000000
--- a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-if test -z "$XDG_RUNTIME_DIR"; then
- export XDG_RUNTIME_DIR=/run/user/$UID
- mkdir --parents $XDG_RUNTIME_DIR
- chmod 0700 $XDG_RUNTIME_DIR
-fi
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
deleted file mode 100644
index f8c0a5fa3..000000000
--- a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
+++ /dev/null
@@ -1,14 +0,0 @@
-FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
-
-SRC_URI_append = "\
- file://weston.sh \
- "
-
-do_install_append() {
- install -d ${D}/${sysconfdir}/profile.d
- install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
-}
-
-FILES_${PN} += " \
- ${sysconfdir}/profile.d/weston.sh \
- "