summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-qcom
diff options
context:
space:
mode:
authorKotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>2017-02-03 10:26:26 +0900
committerKotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>2017-02-03 10:26:26 +0900
commit0a34b88c4b661a91962dd0c04c3af7e582bafcbd (patch)
treeeaa2e7f0725efe029e1bc9fcfc8548b035987b1a /meta-agl-bsp/meta-qcom
parent99804790f0954fc2cf0d20aa4d0a581361d3cfe6 (diff)
weston: Set XDG_RUNTIME_DIR for qcom
Without this environment variable, Weston fails to start on Dragonboard Change-Id: I8863b79c47cde44d7830bc51e4ddc1be64eaff65 Signed-off-by: Kotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>
Diffstat (limited to 'meta-agl-bsp/meta-qcom')
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston-qcom.ini13
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh7
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend20
3 files changed, 40 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston-qcom.ini b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston-qcom.ini
new file mode 100644
index 000000000..3daad91dd
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston-qcom.ini
@@ -0,0 +1,13 @@
+[core]
+backend=drm-backend.so
+shell=ivi-shell.so
+
+[ivi-shell]
+ivi-module=ivi-controller.so,wl-shell-emulator.so
+ivi-input-module=ivi-input-controller.so
+
+[output]
+name=HDMI-A-1
+transform=270
+# Uncomment for 1080p on GeChic 1502i:
+#mode=173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh
new file mode 100644
index 000000000..225a034bb
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston/weston.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+if test -z "$XDG_RUNTIME_DIR"; then
+ export XDG_RUNTIME_DIR=/run/user/$UID
+ mkdir --parents $XDG_RUNTIME_DIR
+ chmod 0700 $XDG_RUNTIME_DIR
+fi
diff --git a/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644
index 000000000..8fff1dfe7
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-graphics/wayland/weston_%.bbappend
@@ -0,0 +1,20 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+SRC_URI_append = "\
+ file://weston-qcom.ini \
+ file://weston.sh \
+ "
+
+do_install_append() {
+ WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
+ install -d ${D}${WESTON_INI_CONFIG}
+ install -m 0644 ${WORKDIR}/weston-qcom.ini ${D}${WESTON_INI_CONFIG}/weston.ini
+
+ install -d ${D}/${sysconfdir}/profile.d
+ install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
+}
+
+FILES_${PN} += " \
+ ${sysconfdir}/xdg/weston/weston.ini \
+ ${sysconfdir}/profile.d/weston.sh \
+ "