summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2019-07-23 19:15:47 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-07-24 18:42:24 +0000
commit5b23f8e5015e4b79f127d91fd0792dbb6a352c94 (patch)
tree9ace8dc882d98153f73f087767b1092bcb1fe0e8 /meta-agl-bsp/meta-raspberrypi
parent896ead7abffcb4b9ea3808eef857520b4201f429 (diff)
rpi-config_git.bbappend: Update for Raspberry Pi 4
Extend the deploy task to support Rasppberry Pi 4. Bug-AGL: SPEC-2656 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Change-Id: I3a166a873b431539e154ef6a2b1e69df02a0f2a3
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
index 9222fd52a..5c74cae7b 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -1,5 +1,24 @@
DISABLE_OVERSCAN = "1"
+do_deploy_append_raspberrypi4() {
+ # ENABLE CAN
+ if [ "${ENABLE_CAN}" = "1" ]; then
+ echo "# Enable CAN" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=mcp2515-can0,oscillator=16000000,interrupt=25" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+
+ # Handle setup with armstub file
+ if [ -n "${ARMSTUB}" ]; then
+ echo "\n# ARM stub configuration" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "armstub=${ARMSTUB}" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ case "${ARMSTUB}" in
+ *-gic.bin)
+ echo "enable_gic=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ ;;
+ esac
+ fi
+}
+
do_deploy_append() {
if [ "${ENABLE_CMA}" = "1" ] && [ -n "${CMA_LWM}" ]; then
sed -i '/#cma_lwm/ c\cma_lwm=${CMA_LWM}' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
@@ -21,3 +40,4 @@ do_deploy_append_sota() {
}
ENABLE_UART_raspberrypi3 = "1"
+ENABLE_UART_raspberrypi4 = "1"