summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-raspberrypi
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-04-11 13:47:10 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2019-04-11 13:47:10 +0200
commitbcd141cb89a8ef1219bad72765c01c14bc93e4c6 (patch)
tree2f331a8ffa6fad60f9ed8f4ad7277b3b21b371c2 /meta-agl-bsp/meta-raspberrypi
parent99cef05b4c32c401868c7f487784130e607ca74c (diff)
Add rpi network drivers by default
This is needed for network booting. Change-Id: Iecee73a3b0bf31c3c68bb4beea1f41d07c9b5ec5 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-raspberrypi')
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/raspberrypi_network.cfg5
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend4
2 files changed, 9 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/raspberrypi_network.cfg b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/raspberrypi_network.cfg
new file mode 100644
index 000000000..aa9649050
--- /dev/null
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/raspberrypi_network.cfg
@@ -0,0 +1,5 @@
+
+CONFIG_USB_NET_SMSC95XX=y
+CONFIG_NETDEVICES=y
+CONFIG_USB_NET_DRIVERS=y
+CONFIG_USB_USBNET=y
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
index 92dd6e7d2..4271926e4 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
@@ -35,3 +35,7 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-panel.cfg"
# Enable bt hci uart
SRC_URI_append = " file://raspberrypi-hciuart.cfg"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-hciuart.cfg"
+
+# ENABLE NETWORK (built-in)
+SRC_URI_append = " file://raspberrypi_network.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi_network.cfg"