summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-bsp
diff options
context:
space:
mode:
authorRonan <ronan.lemartret@iot.bzh>2016-12-02 10:22:14 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-12-02 13:15:40 +0000
commit233363d31f03550cd69a67fdd3e7107863aa3a86 (patch)
treee76ec497c0871545533e69042de34d472ba53e22 /meta-agl-bsp/meta-rcar-gen3/recipes-bsp
parent44217b34e9a77e1e22e3c518379c7d35ad55684e (diff)
optee-os depend on python-pycrypto
* optee-os use python script to build so, We need to add: inherit pythonnative If not we use host python during the build. * During the build, optee-os use script: - scripts/pem_to_pub_c.py - scripts/sign.py Those script depend on python-pycrypto "from Crypto.PublicKey import RSA" So we need to add python-pycrypto native to recipes * The python-pycrypto recipes come from meta-security (out of AGL): https://layers.openembedded.org/layerindex/recipe/39101/ Change-Id: I64340544c9a23a8e9ef62aca348fc08722d3dcc2 Signed-off-by: Ronan <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-bsp')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend
index 90d6717ab..e38c90406 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend
@@ -1,4 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+inherit pythonnative
+DEPENDS += " python-pycrypto-native"
SRC_URI += " \
file://0001-disable-libgcc-detection.patch \