summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-bsp
diff options
context:
space:
mode:
authorRonan <ronan.lemartret@iot.bzh>2017-01-09 08:34:23 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-10 19:38:27 +0000
commit4a421d9443723ca6835568750a80ffba4b117a16 (patch)
treec697b96a028e0a7b04b4756610983f5f89fe0155 /meta-agl-bsp/meta-rcar-gen3/recipes-bsp
parent9d4806d9ccdf72a4cf57704bf124e1432c389ac9 (diff)
fix build with gcc6
Change-Id: I1ce6a5f4fb2d04962234d4b2f9bcfe92140cccc9 Signed-off-by: Ronan <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-bsp')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend
index e38c90406..4845dda22 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bbappend
@@ -2,6 +2,9 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
inherit pythonnative
DEPENDS += " python-pycrypto-native"
+#Need for gcc 6.2
+CFLAGS += " -fno-strict-aliasing -Wno-unused-variable -Wno-shift-negative-value"
+
SRC_URI += " \
file://0001-disable-libgcc-detection.patch \
"