summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-bsp
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-04-29 12:44:27 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-03 21:36:16 +0000
commit888224e3fc13eeaa409cdb0d7879232f93981713 (patch)
tree657093fa7fb928cca8312c759bd2f4c50972ae56 /meta-agl-bsp/meta-rcar-gen3/recipes-bsp
parent7db156af5dcdb17cb8c30c51b7d4cf0a755abd65 (diff)
meta-agl-bsp: add fix for intermittent failures in arm-trusted-firmware
Add a work around in the arm-trusted-firmware bbappend for meta-rcar-gen3 to fix intermittent failures due to a bug in the upstream recipe where it is dependent on something else happening to have run first and creating DEPLOY_DIR_IMAGE. Bug-AGL: SPEC-4343 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ibe43bdb0cf1b525e30ada758e12b687f5dda0d3f Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27431 ci-image-build: Jenkins Job builder account Reviewed-by: Vasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-bsp')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bbappend
index 4ba36ca2c..212c661b1 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bbappend
@@ -3,3 +3,9 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI:append = " \
file://0001-Boot-Normal-World-in-EL2.patch \
"
+
+do_ipl_opt_deploy:prepend () {
+ # Work around bug in BSP recipe, it can fail if nothing else has
+ # happened to run first and create the directory.
+ install -d ${DEPLOY_DIR_IMAGE}
+}