summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2017-10-12 09:20:19 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-12 21:50:49 +0000
commit1f94c21af983630e88e4d7230c817e5e570c6055 (patch)
tree10ff1d8b75ecf9777968868d29957295275e09f9 /meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland
parent151ea4141d2e332b706241aebbd3fb5b206b0072 (diff)
weston-ini-conf: Make this track variables correctly for signatures
bitbake does not know to track values that are found and used via getVarFlags() without them being otherwise refernced and tracked in ways that are otherwise caught. Further given that we use multiple levels of varflags here we need to be explicit in their tracking. Add all variables that we use to varflags where they are added to the metadata. Bug-AGL: SPEC-939 Change-Id: I32cf16c4354d733e086c6ea9a845934beff94715 Signed-off-by: Tom Rini <trini@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11255 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
index e46b10ef7..661af2b92 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -10,3 +10,5 @@ python() {
if "multimedia" in d.getVar("MACHINE_FEATURES", True).split(" "):
d.setVarFlag("WESTONSECTION", "WESTONV4L2RENDERER", "v4l2-renderer")
}
+
+do_generate_weston_init[vardeps] += "WESTONIVISHELL WESTONV4L2RENDERER"