summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-graphics
diff options
context:
space:
mode:
authorDuy Dang <duy.dang.yw@renesas.com>2020-02-26 15:34:38 +0700
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-03-18 12:40:52 +0000
commit2fe60ed6b40ae96e43d1edd9c3da978dc6e8db0c (patch)
tree4df13eb28040bacaffb502a0db19437016f4e695 /meta-agl-bsp/meta-rcar-gen3/recipes-graphics
parentfbb9935ee800146d931dbdb53a9626e5d90db27c (diff)
Support Salvator-X/XS board
Add new machines to build with AGL: - h3-salvator-x-nogfx - h3-salvator-x - m3-salvator-x-nogfx - m3-salvator-x Bug-AGL: SPEC-3169 Change-Id: I0cfa838ad40f8afda01aeb693fbf595bad8b4730 Signed-off-by: Duy Dang <duy.dang.yw@renesas.com>
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-graphics')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend5
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/ebisu_output.cfg9
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/kingfisher_output.cfg1
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/salvator-x_output.cfg12
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend2
5 files changed, 24 insertions, 5 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
index 198f83f10..44615c331 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -1,7 +1,8 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI += "file://kingfisher_output.cfg"
-SRC_URI_append_ebisu += "file://ebisu_output.cfg"
+SRC_URI_append_ulcb = " file://kingfisher_output.cfg"
+SRC_URI_append_ebisu = " file://ebisu_output.cfg"
+SRC_URI_append_salvator-x = " file://salvator-x_output.cfg"
do_configure() {
echo repaint-window=34 >> ${WORKDIR}/core.cfg
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/ebisu_output.cfg b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/ebisu_output.cfg
index 618f04e71..2bca54f02 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/ebisu_output.cfg
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/ebisu_output.cfg
@@ -1,4 +1,11 @@
[output]
-name=VGA-1
+name=HDMI-A-2
+mode=off
+
+[output]
+name=LVDS-1
mode=off
+[output]
+name=VGA-1
+mode=off
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/kingfisher_output.cfg b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/kingfisher_output.cfg
index a194a4a46..99fde3063 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/kingfisher_output.cfg
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/kingfisher_output.cfg
@@ -5,4 +5,3 @@ mode=off
[output]
name=LVDS-1
mode=off
-
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/salvator-x_output.cfg b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/salvator-x_output.cfg
new file mode 100644
index 000000000..7359e6ec9
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/salvator-x_output.cfg
@@ -0,0 +1,12 @@
+[output]
+name=HDMI-A-2
+mode=off
+
+[output]
+name=LVDS-1
+mode=off
+
+[output]
+name=VGA-1
+mode=off
+
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
index 38590dcdb..6ce747270 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
@@ -1 +1 @@
-DEPENDS_append_ulcb = " gstreamer1.0-plugins-base"
+DEPENDS_append_rcar-gen3 = " gstreamer1.0-plugins-base"