summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-gles
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-05-03 14:22:51 -0400
committerScott Murray <scott.murray@konsulko.com>2022-05-06 11:39:01 +0000
commit4f5cf5dc8de803407fa9d3ffa13994309edde985 (patch)
treef00561c7bcf8677f95f65f6206dd3c705275401f /meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-gles
parent080086bc5062a1eb025b82051884aaa508f50408 (diff)
Enable usrmerge
An increasing number of advanced systemd features with respect to immutable systems and sandboxing are effectively dependent on the usrmerge distro feature, so it seems reasonable to enable it since upstream AGL currently requires systemd usage. See SPEC-4352 for more detailed discussion of rationale. Changes: - Add usrmerge to AGL_DEFAULT_DISTRO_FEATURES in poky-agl.conf. - Add workarounds via bbappends in meta-agl-bsp for the assumption of using /lib instead of ${nonarch_base_libdir} in various meta-rcar-gen3 kernel module recipes. This will be followed up with upstream to hopefully fix the recipes. - Replaced some explicit /sbin usage with ${sbindir} in the initramfs-netboot recipe used by the agl-netboot feature to avoid packaging errors. Bug-AGL: SPEC-4352 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ibc0ae1e2628aca6474401e0852bbb97085f4ecfa Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27437 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-gles')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bbappend15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bbappend
index b8882ae49..6b9768394 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/kernel-module-gles/kernel-module-gles.bbappend
@@ -4,3 +4,18 @@ module_do_compile:prepend() {
cd ${S}/build/linux/config/compilers
cp aarch64-linux-gnu.mk ${TARGET_SYS}.mk
}
+
+do_install:append() {
+ # Work around upstream not using ${nonarch_base_libdir}/modules
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', 'true', 'false', d)}; then
+ install -d ${D}${nonarch_base_libdir}/
+ mv ${D}/lib/modules ${D}${nonarch_base_libdir}/
+ rm -rf ${D}/lib
+ fi
+}
+
+# Required to guarantee the module goes into the expected
+# kernel-module-gles package and doesn't end up packaged in
+# kernel-module-pvrsvkm by the default behavior. Can be removed
+# if upstream correctly use ${nonarch_base_libdir} themselves.
+FILES:${PN} += "${nonarch_base_libdir}/modules/${KERNEL_VERSION}/extra/pvrsrvkm.ko"