summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rcar-gen3
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2020-10-07 08:59:55 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-10-15 20:53:44 +0000
commit6f2a36574b49042d71d33c0019ebff5decde8f65 (patch)
treec5461a346348303690ba5f69b8bdfa4eb83c9cc2 /meta-agl-bsp/meta-rcar-gen3
parent6d46b8cb03890d899af2bf6e5222dc0954836c90 (diff)
[RCAR] Fix smack rule for pvr device
The GL driver needs to access to the powervr sync device /dev/pvr_sync (provided by gles-user-module). If a graphic application wants access to display (SupplementaryGroups=display), and so GL access, the ACL on /dev/pvr_sync must have: - a smack label "*" - a dac (group display) m3ulcb:~# ls -lZ /dev/pvr_sync crw-rw----. 1 root display * 10, 59 Jun 29 03:06 /dev/pvr_sync Bug-AGL: [SPEC-3617] Change-Id: Ia6472424ac07c60a5c16cb6f48174481e8dd759d Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25415 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-by: Stéphane Desneux <stephane.desneux@iot.bzh> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-rcar-gen3')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend
index b902fc9b6..707778cde 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend
@@ -1 +1,6 @@
require checksum_control.inc
+
+do_install_append(){
+ sed -i 's/MODE="0660", OWNER/MODE="0660", SECLABEL{smack}="*", OWNER/g' ${D}${sysconfdir}/udev/rules.d/72-pvr-seat.rules
+ sed -i 's/GROUP="video"/GROUP="display"/g' ${D}${sysconfdir}/udev/rules.d/72-pvr-seat.rules
+}