summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hibernation/0007-Add-rcar-i2c-hibernation-code.patch
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-02-14 10:55:35 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-02-14 10:55:35 +0100
commit317c8a08a6b5943517e67c5ea80b0a9a83a10d63 (patch)
treebf2b27dc9068924b59b46d2e153936c77be954c3 /meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hibernation/0007-Add-rcar-i2c-hibernation-code.patch
parentb6dc44f585b839ab1a2f0133b74958037fe1cb64 (diff)
parentc9ce37905acd879db107eafe309678053073e086 (diff)
Merge remote-tracking branch 'agl/sandbox/ronan/rocko' into HEAD
* agl/sandbox/ronan/rocko: (58 commits) Update ulcb conf file Remove unsed gstreamer backport [GEN3] add preferred version on omx package run-(agl-)postinst: Emit progress to console meta-security: Remove unused content Upgrade wayland-ivi-extension Revert "Fix kernel gcc7 issue" remove backport commit Revert "Fix CVE-2017-1000364 by backporting the patches for gen3" Remove fix for optee-os Remove gcc 6 fix Update rcar gen3 kernel bbappend version Update rcar gen3 driver Remove porter machine dbus-cynara: Upgrade to 1.10.20 xmlsec1: switch to meta-security version systemd: earlier smack label switch cynara: upgrade to 0.14.10 Remove smack recipe Integrate parts of meta-intel-iot-security ... Bug-AGL: SPEC-1181 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Conflicts: meta-app-framework/recipes-security/cynara/cynara_git.bbappend Change-Id: I9875fcb31e960038ce6c23165c99b52a3bd1a1c0
Diffstat (limited to 'meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hibernation/0007-Add-rcar-i2c-hibernation-code.patch')
-rwxr-xr-xmeta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hibernation/0007-Add-rcar-i2c-hibernation-code.patch69
1 files changed, 0 insertions, 69 deletions
diff --git a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hibernation/0007-Add-rcar-i2c-hibernation-code.patch b/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hibernation/0007-Add-rcar-i2c-hibernation-code.patch
deleted file mode 100755
index bba1eb401..000000000
--- a/meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux/hibernation/0007-Add-rcar-i2c-hibernation-code.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 6c133013b75d88d5b4514dfecb3089f830b82d65 Mon Sep 17 00:00:00 2001
-From: Yuichi Kusakabe <yuichi.kusakabe@jp.fujitsu.com>
-Date: Thu, 18 May 2017 17:35:37 +0900
-Subject: [PATCH 07/15] Add rcar-i2c hibernation code
-
-Signed-off-by: Yuichi Kusakabe <yuichi.kusakabe@jp.fujitsu.com>
----
- drivers/i2c/busses/i2c-rcar.c | 38 ++++++++++++++++++++++++++++++++++++++
- 1 file changed, 38 insertions(+)
-
-diff --git a/drivers/i2c/busses/i2c-rcar.c b/drivers/i2c/busses/i2c-rcar.c
-index 8242002..c6a5a4b 100644
---- a/drivers/i2c/busses/i2c-rcar.c
-+++ b/drivers/i2c/busses/i2c-rcar.c
-@@ -754,6 +754,43 @@ static int rcar_i2c_probe(struct platform_device *pdev)
-
- return 0;
- }
-+static int rcar_i2c_suspend(struct device *dev)
-+{
-+ struct platform_device *pdev = to_platform_device(dev);
-+ struct rcar_i2c_priv *priv = platform_get_drvdata(pdev);
-+ pr_debug("suspend: i2c adapter name %s", priv->adap.name);
-+ pr_debug("suspend: ICSCR: %08x\n", readl(priv->io + ICSCR));
-+ pr_debug("suspend: ICMCR: %08x\n", readl(priv->io + ICMCR));
-+ pr_debug("suspend: ICSSR: %08x\n", readl(priv->io + ICSSR));
-+ pr_debug("suspend: ICMSR: %08x\n", readl(priv->io + ICMSR));
-+ pr_debug("suspend: ICSIER: %08x\n", readl(priv->io + ICSIER));
-+ pr_debug("suspend: ICMIER: %08x\n", readl(priv->io + ICMIER));
-+ pr_debug("suspend: ICCCR: %08x\n", readl(priv->io + ICCCR));
-+ pr_debug("suspend: ICSAR: %08x\n", readl(priv->io + ICSAR));
-+ pr_debug("suspend: ICMAR: %08x\n", readl(priv->io + ICMAR));
-+ clk_disable(priv->clk);
-+ return 0;
-+}
-+static int rcar_i2c_resume(struct device *dev)
-+{
-+ struct platform_device *pdev = to_platform_device(dev);
-+ struct rcar_i2c_priv *priv = platform_get_drvdata(pdev);
-+ clk_enable(priv->clk);
-+ pr_debug("resume: i2c adapter name %s", priv->adap.name);
-+ pr_debug("resume: ICSCR: %08x\n", readl(priv->io + ICSCR));
-+ pr_debug("resume: ICMCR: %08x\n", readl(priv->io + ICMCR));
-+ pr_debug("resume: ICSSR: %08x\n", readl(priv->io + ICSSR));
-+ pr_debug("resume: ICMSR: %08x\n", readl(priv->io + ICMSR));
-+ pr_debug("resume: ICSIER: %08x\n", readl(priv->io + ICSIER));
-+ pr_debug("resume: ICMIER: %08x\n", readl(priv->io + ICMIER));
-+ pr_debug("resume: ICCCR: %08x\n", readl(priv->io + ICCCR));
-+ pr_debug("resume: ICSAR: %08x\n", readl(priv->io + ICSAR));
-+ pr_debug("resume: ICMAR: %08x\n", readl(priv->io + ICMAR));
-+ return 0;
-+}
-+static const struct dev_pm_ops rcar_i2c_pm_ops = {
-+ SET_SYSTEM_SLEEP_PM_OPS(rcar_i2c_suspend, rcar_i2c_resume)
-+};
-
- static int rcar_i2c_remove(struct platform_device *pdev)
- {
-@@ -780,6 +817,7 @@ static struct platform_driver rcar_i2c_driver = {
- .name = "i2c-rcar",
- .owner = THIS_MODULE,
- .of_match_table = rcar_i2c_dt_ids,
-+ .pm = &rcar_i2c_pm_ops,
- },
- .probe = rcar_i2c_probe,
- .remove = rcar_i2c_remove,
---
-1.8.3.1
-