summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-rockchip/recipes-graphics
diff options
context:
space:
mode:
authorNaoto Yamaguchi <naoto.yamaguchi@aisin.co.jp>2024-07-24 07:18:48 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2024-09-17 08:58:22 +0000
commit6debcd5420b798dd8c0b3052620cc5d8f3bcbff7 (patch)
tree3283a34242e08477560db7fc33904a4b60ec3e0c /meta-agl-bsp/meta-rockchip/recipes-graphics
parent28b6f10df1bb46d266463ffd7f4bc260644e14a2 (diff)
Add support NanoPC-T6(RK3588) board
This patch add NanoPC-T6 board support to AGL that board is manufactured by FriendlyElec. Board info. https://wiki.friendlyelec.com/wiki/index.php/NanoPC-T6 Bug-AGL: SPEC-5208 Change-Id: Id1b6d9c6f73ece2b3a2f602405f534473e8bcbf2 Signed-off-by: Naoto Yamaguchi <naoto.yamaguchi@aisin.co.jp> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/30168 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account
Diffstat (limited to 'meta-agl-bsp/meta-rockchip/recipes-graphics')
-rw-r--r--meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/agl-compositor-init.bbappend7
-rw-r--r--meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/agl-compositor-init/agl-compositor-rockchip.conf2
-rw-r--r--meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/weston-ini-conf.bbappend7
-rw-r--r--meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/weston-ini-conf/nanopct6_output.cfg7
4 files changed, 23 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/agl-compositor-init.bbappend b/meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/agl-compositor-init.bbappend
new file mode 100644
index 000000000..ab14bdbc2
--- /dev/null
+++ b/meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/agl-compositor-init.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI:append = " file://agl-compositor-rockchip.conf "
+
+do_install:append() {
+ install -m644 ${WORKDIR}/agl-compositor-rockchip.conf ${D}/${systemd_system_unitdir}/agl-compositor.service.d/agl-compositor-rockchip.conf
+}
diff --git a/meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/agl-compositor-init/agl-compositor-rockchip.conf b/meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/agl-compositor-init/agl-compositor-rockchip.conf
new file mode 100644
index 000000000..e85d7fa91
--- /dev/null
+++ b/meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/agl-compositor-init/agl-compositor-rockchip.conf
@@ -0,0 +1,2 @@
+[Service]
+Environment=LD_PRELOAD=/usr/lib/libmali.so.1
diff --git a/meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/weston-ini-conf.bbappend b/meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/weston-ini-conf.bbappend
new file mode 100644
index 000000000..a7bebe3fc
--- /dev/null
+++ b/meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/weston-ini-conf.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI:append = " \
+ file://nanopct6_output.cfg \
+"
+
+WESTON_FRAGMENTS:append:nanopct6 = " nanopct6_output"
diff --git a/meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/weston-ini-conf/nanopct6_output.cfg b/meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/weston-ini-conf/nanopct6_output.cfg
new file mode 100644
index 000000000..fbee86693
--- /dev/null
+++ b/meta-agl-bsp/meta-rockchip/recipes-graphics/wayland/weston-ini-conf/nanopct6_output.cfg
@@ -0,0 +1,7 @@
+[output]
+name=HDMI-A-2
+mode=off
+
+[output]
+name=DP-1
+transform=rotate-90