summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-06-30 21:45:45 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-07-07 18:22:48 +0000
commit05fd1a84882f4d992519e023a8ef40c017701776 (patch)
treeb35bc8318b8598794dddc498192b5f71cddddd0d /meta-agl-bsp
parent0524237a83de69a0877ea4775ebdd061441ade29 (diff)
Apply the perf fix only when meta-rcar-gen3-adas is not present
Currently the upstream rcar bsp does need the fix for building perf. The meta-rcar-gen3-adas layer contains a fix in the big patchqueue. Thus conditionally apply the perf build fix. Bug-AGL: SPEC-3443 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Change-Id: Icbf53add71ed731c35dec149841691c82ae4372c Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/24914 Reviewed-by: Stéphane Desneux <stephane.desneux@iot.bzh>
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_%.bbappend (renamed from meta-agl-bsp/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_%.bbappendNOT)11
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend10
2 files changed, 8 insertions, 13 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_%.bbappendNOT b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_%.bbappend
index 1ed92af03..7ebe36ad5 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_%.bbappendNOT
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_%.bbappend
@@ -1,14 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI_append_ulcb = " \
- file://0001-arm64-dts-renesas-preserve-drm-HDMI-connector-naming.patch \
- file://disable_most.cfg \
- file://0004-ADSP-enable-and-add-sound-hardware-abstraction_kf.patch \
-"
-
-SRC_URI_remove_ulcb = " \
- file://0113-arm64-dts-ulcb-kf-increase-SDIO-frequency-for-WLAN-c.patch \
-"
+# disable the perf fix as the cogent layer contains it
+perfFIX = ""
KERNEL_DEVICETREE_remove_h3ulcb = " \
renesas/r8a7795-es1-h3ulcb-view.dtb \
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
index 405fc97a0..43aeb6272 100644
--- a/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
@@ -5,14 +5,16 @@ require recipes-kernel/linux/linux-agl.inc
SRC_URI_append = " file://namespace_fix.cfg \
"
+# This can fix a compilation issue with perf. As this seems to collide with the cogent layer
+# we apply this here by variable and reset it when the -adas layer is present.
+perfFIX ??= " file://9999-perf-libbft-upstream.patch "
+#
+
# Add ADSP patch to enable and add sound hardware abstraction
SRC_URI_append_ulcb = " \
file://0004-ADSP-enable-and-add-sound-hardware-abstraction.patch \
+ ${perfFIX} \
"
-# This can fix a compilation issue with perf. This seems to collide with the cogent layer
-# so for now just don't apply and see if or where we need this.
-# file://9999-perf-libbft-upstream.patch \
-#
# For Xen
SRC_URI_append = " \