summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorRonan <ronan.lemartret@iot.bzh>2017-01-09 08:36:26 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-01-10 19:39:03 +0000
commitbab7debd03d46733ff39ce86b2221f5387b36019 (patch)
tree276deefd583cae5f06b7779546b3b1bd0bf1336f /meta-agl-bsp
parent5a98d74d318a2ed2940c3ec15d13f1dffaeacebf (diff)
fix tar command option
* the option "-C XXX" must be set in first position. Change-Id: I89f21e9491a03d53ee9ed047e2ae267ad481fdf6 Signed-off-by: Ronan <ronan.lemartret@iot.bzh>
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/omx-module/omx-user-module.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/omx-module/omx-user-module.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/omx-module/omx-user-module.bbappend
new file mode 100644
index 000000000..b35c614c3
--- /dev/null
+++ b/meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/omx-module/omx-user-module.bbappend
@@ -0,0 +1,8 @@
+setup_build_tree() {
+ for omxmc in ${OMX_COMMON_SRC} ${OMX_VIDEO_DEC_COMMON_SRC} ${OMX_VIDEO_ENC_COMMON_SRC}
+ do
+ tar xf ${WORKDIR}/${omxmc}.tar.bz2 -C ${WORKDIR}
+ tar xf ${WORKDIR}/${omxmc}.tar.bz2 -C ${S} ${omxmc}/src --strip=2
+ tar xf ${WORKDIR}/${omxmc}.tar.bz2 -C ${S} ${omxmc}/include --strip=1
+ done
+}