summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-04-01 12:57:34 -0400
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-04-27 17:12:24 +0200
commitbe9c8115c8f9665586b874098a91f925a6896d95 (patch)
tree7954aabc294054bd78e587281e06bc6aa4438131 /meta-agl-bsp
parent31f3a5659145c9edb64ec71503a9fd639a5b170e (diff)
meta-agl-bsp: update raspberrypi configuration for dunfell
Changes: - Remove Mesa version over-ride, since dunfell has newer version. - Remove bcm2835-bootfiles SRCREV updates since dunfell has newer versions of the files. - Remove kernel SRCREV update in linux-raspberrypi_4.19.bbappend since dunfell has newer version, and add include of new linux-4.19-agl.inc to keep getting CAN qdisc patch. Bug-AGL: SPEC-3302 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I7f7a9b454de9eb4fae7075b30ee89b3aec4e6a43
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/conf/include/agl_raspberrypi3.inc3
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend11
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2020.01.bbappend (renamed from meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend)0
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.19.bbappend7
4 files changed, 1 insertions, 20 deletions
diff --git a/meta-agl-bsp/conf/include/agl_raspberrypi3.inc b/meta-agl-bsp/conf/include/agl_raspberrypi3.inc
index c03702efd..1b958289d 100644
--- a/meta-agl-bsp/conf/include/agl_raspberrypi3.inc
+++ b/meta-agl-bsp/conf/include/agl_raspberrypi3.inc
@@ -19,9 +19,6 @@ RPI_KERNEL_DEVICETREE_remove_raspberrypi3 = "bcm2708-rpi-0-w.dtb"
RPI_KERNEL_DEVICETREE_OVERLAYS_remove_raspberrypi3 = "overlays/lirc-rpi.dtbo"
RPI_KERNEL_DEVICETREE_OVERLAYS_append_raspberrypi3 = " overlays/vc4-fkms-v3d.dtbo"
-# Set appropriate version of Mesa for Raspberry Pi 3 and 4
-PREFERRED_VERSION_mesa = "19.1%"
-
MACHINE_FEATURES += "vc4graphics"
# Switch to firmware KMS to support the official DSI touchscreen display
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
index fc1ba88c3..adb19c09c 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/bootfiles/bcm2835-bootfiles.bbappend
@@ -1,12 +1 @@
RDEPENDS_${PN}_append_sota += " u-boot-otascript"
-
-RPIFW_DATE = "20191021"
-SRCREV = "ed238d3329e39a68bde03bbc2dfc293c0c3dc93a"
-RPIFW_SRC_URI = "https://github.com/raspberrypi/firmware/archive/${SRCREV}.tar.gz"
-RPIFW_S = "${WORKDIR}/firmware-${SRCREV}"
-
-SRC_URI = "${RPIFW_SRC_URI}"
-SRC_URI[md5sum] = "d18066531018a972ed927a6cc136cfff"
-SRC_URI[sha256sum] = "82048cf88f4f50f7cf83e34d93923ceb5147885761d33ee5f4dc980b4a7a426a"
-
-PV = "${RPIFW_DATE}"
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2020.01.bbappend
index ba2ecb599..ba2ecb599 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2019.07.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-bsp/u-boot/u-boot_2020.01.bbappend
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.19.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.19.bbappend
index cc9bcadcd..782d61597 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.19.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.19.bbappend
@@ -1,9 +1,4 @@
-# Update Linux kernel for Raspberry Pi to 4.19.80. This version
-# allows to run firmware KMS to support output through HDMI and
-# DSI for the official 7" Raspberry Pi touch screen display.
-# Bug-AGL: SPEC-2465
-LINUX_VERSION = "4.19.80"
-SRCREV = "3492a1b003494535eb1b17aa7f258469036b1de7"
+require recipes-kernel/linux/linux-agl-4.19.inc
ENABLE_UART_raspberrypi4 = "1"