summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 07:37:25 -0400
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2024-12-11 20:41:32 +0000
commit21a22cadf07c8a42a20a7765bcf05bc1aaf2273a (patch)
tree2783328ba79a172473eb95ee7bb9b00f0a49a514 /meta-agl-bsp
parenta5b07f0c4dc7b734e2e3cbc1675b3ef9ce032aa7 (diff)
Update recipes for transition to UNPACKDIR
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I32e277e15e5aa1ac93dadc67199dedd148d3d0b9 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend9
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb7
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb10
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/si-tools/si-init_1.0.bb5
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend5
5 files changed, 24 insertions, 12 deletions
diff --git a/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend b/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
index 3cd5aa7de..4407b1011 100644
--- a/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
+++ b/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
@@ -5,18 +5,21 @@ SRC_URI = "file://gpsd.refhw \
file://refhw.conf \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit update-alternatives
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
- install -D -m 0644 ${WORKDIR}/gpsd.refhw ${D}/${sysconfdir}/default/gpsd.refhw
+ install -D -m 0644 ${UNPACKDIR}/gpsd.refhw ${D}/${sysconfdir}/default/gpsd.refhw
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -D -m 0755 ${WORKDIR}/refhw-gpsd-helper.sh ${D}/${sbindir}/refhw-gpsd-helper.sh
+ install -D -m 0755 ${UNPACKDIR}/refhw-gpsd-helper.sh ${D}/${sbindir}/refhw-gpsd-helper.sh
install -d ${D}${sysconfdir}/systemd/system/gpsd.service.d
- install -D -m 0644 ${WORKDIR}/refhw.conf ${D}${sysconfdir}/systemd/system/gpsd.service.d/refhw.conf
+ install -D -m 0644 ${UNPACKDIR}/refhw.conf ${D}${sysconfdir}/systemd/system/gpsd.service.d/refhw.conf
fi
}
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb b/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb
index 798fcebe6..df8f62937 100644
--- a/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-connectivity/hci-uart-helper/hci-uart-helper_1.0.bb
@@ -8,6 +8,9 @@ SRC_URI = "file://hci-uart-helper.service \
file://hci-uart-helper.sh \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
COMPATIBLE_MACHINE = "imx8mq-evk"
do_configure[noexec] = "1"
@@ -16,11 +19,11 @@ do_compile[noexec] = "1"
do_install() {
# Install helper script
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/hci-uart-helper.sh ${D}${sbindir}/
+ install -m 0755 ${UNPACKDIR}/hci-uart-helper.sh ${D}${sbindir}/
# Install systemd unit
install -d ${D}${systemd_system_unitdir}/
- install -m 0644 ${WORKDIR}/hci-uart-helper.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${UNPACKDIR}/hci-uart-helper.service ${D}${systemd_system_unitdir}/
install -d ${D}${systemd_system_unitdir}/bluetooth.service.wants
ln -s ../hci-uart-helper.service ${D}${systemd_system_unitdir}/bluetooth.service.wants/
}
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
index c5edbe1dc..464ae3f6f 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/create-combined-dtb/create-combined-dtb_1.0.0.bb
@@ -1,16 +1,13 @@
SUMMARY = "Combine dtb and dtbo"
DESCRIPTION = "Combine specified dtb and one or more dtbo into specified filename found in deploydir"
SECTION = "bootloader"
-PR = "r1"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
DEPENDS = "dtc-native"
-ALLOW_EMPTY:${PN} = "1"
-FILES:${PN} = ""
-
-S = "${WORKDIR}"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
do_compile[depends] += "virtual/kernel:do_deploy"
@@ -41,3 +38,6 @@ do_deploy () {
}
addtask deploy after do_install
+
+ALLOW_EMPTY:${PN} = "1"
+FILES:${PN} = ""
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/si-tools/si-init_1.0.bb b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/si-tools/si-init_1.0.bb
index b53504400..6804fbbb9 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/si-tools/si-init_1.0.bb
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-bsp/si-tools/si-init_1.0.bb
@@ -6,12 +6,15 @@ inherit systemd
SRC_URI = "file://si-init.service"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
install -d ${D}${systemd_system_unitdir}
- install -m 0644 ${WORKDIR}/si-init.service ${D}${systemd_system_unitdir}
+ install -m 0644 ${UNPACKDIR}/si-init.service ${D}${systemd_system_unitdir}
# Add symlink to sysinit.target.wants
install -d ${D}${sysconfdir}/systemd/system/sysinit.target.wants
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
index 51604706c..f82e17170 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
@@ -2,6 +2,9 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI = "file://gpsd.kingfisher"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit update-alternatives
do_configure[noexec] = "1"
@@ -9,7 +12,7 @@ do_compile[noexec] = "1"
do_install() {
install -d ${D}/${sysconfdir}/default
- install -m 0644 ${WORKDIR}/gpsd.kingfisher ${D}/${sysconfdir}/default/gpsd.kingfisher
+ install -m 0644 ${UNPACKDIR}/gpsd.kingfisher ${D}/${sysconfdir}/default/gpsd.kingfisher
}
COMPATIBLE_MACHINE = "ulcb"