summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-04-29 12:16:55 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-03 21:36:16 +0000
commit7d1de66a0356c2400c8d616649986d4d232ae79e (patch)
tree64211507e844d66a90e82941e45ed4f85b79ac98 /meta-agl-bsp
parentfa02bbe2f1661e3a54c17197d2ba1aa5b6826448 (diff)
meta-agl-bsp: avoid meta-gnome dependency from meta-rcar-gen3
The kirkstone-dev_3.5_M3_v5.9.0 branch of meta-renesas contains a new bbappend for cogl which requires meta-gnome. Since nothing in the BSP layer itself depends on cogl, and there is currently no obvious usecase for cogl outside of GNOME desktop related libraries, BBMASK out the bbappend so we do not need to pull in meta-gnome. This can be revisited if an AGL member presents a need for cogl on rcar3 in their downstream use of AGL. Ideally, upstream will move the bbappend to a dynamic layer directory to remove the issue. Bug-AGL: SPEC-4343 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6e55c07d1ff1fd7d68d1798ecca3c9c1b35cdf14 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27428 Reviewed-by: Vasyl Vavrychuk <vasyl.vavrychuk@opensynergy.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar-nogfx.inc3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc b/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
index eb29f1a43..48706caf8 100644
--- a/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
+++ b/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
@@ -45,3 +45,6 @@ PSEUDO_IGNORE_PATHS:append:pn-kernel-module-vspm = ",${KERNELSRC}"
# Mask out base-files and systemd bbappends to avoid changing systemd-tmpfiles
# behavior, see SPEC-4256 for a more involved explanation.
BBMASK += "meta-rcar-gen3/recipes-core/base-files/ meta-rcar-gen3/recipes-core/systemd/"
+
+# Mask out cogl bbappend to avoid meta-gnome dependency
+BBMASK += "meta-rcar-gen3/recipes-graphics/cogl/cogl-1.0_1.%.bbappend"