summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
authorronan <ronan.lemartret@iot.bzh>2020-12-15 21:17:10 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-12-17 13:47:06 +0000
commitc1e048fc05542d859115990312e0753ce2dea72e (patch)
tree358ef537e41ebc97c0f9fb2ee8cd1dc748ba6adb /meta-agl-bsp
parenta39849e1170bc931ca5bbcbae1445fabb8ca25cd (diff)
[RCAR] disable a default config in kernel
The meta-rcar layer activates by default the configuration MTD_RENESAS_RPC_HYPERFLASH in kernel. MTD_RENESAS_RPC_HYPERFLASH is not upstream, it's a meta-rcar specific feature. MTD_RENESAS_RPC_HYPERFLASH feature in the kernel need an firmware update on the board and can be considered (IMHO) as a security issues in production. We need to set DISABLE_RPC_ACCESS to deactivate it. v2 (jsmoeller): Use ?= for DISABLE_RPC_ACCESS . Bug-AGL: SPEC-3674 Signed-off-by: ronan <ronan.lemartret@iot.bzh> Change-Id: Iefaf9ca115d1fb805b0d3766fc0c800b74daecee Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25815 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_%.bbappend b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_%.bbappend
index 36e0caf34..def762bf7 100644
--- a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_%.bbappend
+++ b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_%.bbappend
@@ -24,3 +24,7 @@ KERNEL_DEVICETREE_remove_h3ulcb = " \
renesas/r8a7795-h3ulcb-4x2g-vb2.1.dtb \
renesas/r8a7795-h3ulcb-4x2g-vbm.dtb \
"
+
+# The meta-rcar layer actives by default the configuration MTD_RENESAS_RPC_HYPERFLASH
+# in the kernel. We need to set DISABLE_RPC_ACCESS to deactivate it.
+DISABLE_RPC_ACCESS ?= "1"