summaryrefslogtreecommitdiffstats
path: root/meta-agl-core/conf/distro/poky-agl.conf
diff options
context:
space:
mode:
authorPaul Barker <pbarker@konsulko.com>2021-01-11 17:25:18 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-12 15:40:31 +0000
commit67248e369aac29a94797f2f6bb52ee162f6ca378 (patch)
treef676f089ce53ef0f888affa43d9d82dfa9cc9f56 /meta-agl-core/conf/distro/poky-agl.conf
parentdd6777dfdacc691402cde0e349e9987a481efe3a (diff)
Improve workaround for do_image_wic race condition
This change ensures that no other do_image_* task can be running and reading the rootfs directory at the same time as do_image_wic is modifying the /etc/fstab file in the rootfs directory. It can be removed when the more efficient but more complex fix is accepted and backported upstream in poky. Further details are given in the new image_types_wic_workaround.bbclass file. This allows us to remove the previous workaround of running wic with the `--no-fstab-update` argument and so the fstab file in wic images will now include all partitions. Bug-AGL: SPEC-3621 Signed-off-by: Paul Barker <pbarker@konsulko.com> Change-Id: Ibdbed7164c8684f50e917b5c877508d8c968d73b Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25884 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-core/conf/distro/poky-agl.conf')
-rw-r--r--meta-agl-core/conf/distro/poky-agl.conf4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-agl-core/conf/distro/poky-agl.conf b/meta-agl-core/conf/distro/poky-agl.conf
index 6d25af90f..f2b622190 100644
--- a/meta-agl-core/conf/distro/poky-agl.conf
+++ b/meta-agl-core/conf/distro/poky-agl.conf
@@ -203,6 +203,4 @@ BBMASK += "meta-security/recipes-kernel/linux/linux-%_5.%.bbappend"
# do_image_tar and do_image_ext4 can run in parallel
# This needs to be fixed upstream:
# See https://bugzilla.yoctoproject.org/show_bug.cgi?id=13994
-# For convenience restricted to ext4 and tar image types.
-AGL_FORBID_FSTAB_UPDATE ?= "${@bb.utils.contains_any('IMAGE_FSTYPES', 'ext4 ext4.xz tar tar.gz tar.bz2 tar.xz', '--no-fstab-update', '', d)}"
-WIC_CREATE_EXTRA_ARGS_append = " ${AGL_FORBID_FSTAB_UPDATE}"
+INHERIT += "image_types_wic_workaround"