summaryrefslogtreecommitdiffstats
path: root/meta-agl-core
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-01-16 17:04:08 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2023-01-29 14:30:03 +0000
commit327a0d5a3b550fe418080bbee934d210b8783b3b (patch)
tree95c2b7a77e0ac3e40925ee51ffd4a5392fc5073b /meta-agl-core
parentb9d4796f44a56c6a9c8233d82e46c251a82f6020 (diff)
weston-ini-conf: make remote output configuration dynamic
Rework things to also update the remote output configuration fragment based on the value of TRANSMITTER_OUTPUT_HOST. This helps when using different IP addresses for e.g. the KVM demo configuration. Bug-AGL: SPEC-4618 Change-Id: I198ff3e6a30b3968b4749998354a39325c088933 Signed-off-by: Scott Murray <scott.murray@konsulko.com> (cherry picked from commit 39def8ebd98c98e67304517ab118f9bde4cdf8e7) Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28415 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-core')
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb6
-rw-r--r--meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg.in (renamed from meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg)0
2 files changed, 5 insertions, 1 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
index 50e51348a..ae5eb5565 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf.bb
@@ -9,7 +9,7 @@ SRC_URI = " \
file://hdmi-a-1-90.cfg \
file://hdmi-a-1-180.cfg \
file://hdmi-a-1-270.cfg \
- file://remote-output.cfg \
+ file://remote-output.cfg.in \
file://transmitter-output.cfg.in \
file://virtual-0.cfg \
file://virtual-90.cfg \
@@ -43,6 +43,9 @@ do_configure() {
-e "s#host=.*#host=${TRANSMITTER_OUTPUT_HOST}#" \
-e "s#port=.*#port=${TRANSMITTER_OUTPUT_PORT}#" \
${WORKDIR}/transmitter-output.cfg.in > ${WORKDIR}/transmitter-output.cfg
+ sed -e "s#host=.*#host=${TRANSMITTER_OUTPUT_HOST}#" \
+ -e "s#port=.*#port=${TRANSMITTER_OUTPUT_PORT}#" \
+ ${WORKDIR}/remote-output.cfg.in > ${WORKDIR}/remote-output.cfg
}
do_compile() {
@@ -62,6 +65,7 @@ do_compile() {
# and a corresponding landscape-inverted that is 180 degrees
# rotated.
rm -f ${WORKDIR}/weston.ini.landscape
+ rm -f ${WORKDIR}/weston.ini.landscape-inverted
for F in ${WESTON_FRAGMENTS}; do
INVF=$F
if echo $F | grep '^hdmi-a-1-\(90\|270\)$'; then
diff --git a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg.in
index 940cbdd0c..940cbdd0c 100644
--- a/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg
+++ b/meta-agl-core/recipes-graphics/wayland/weston-ini-conf/remote-output.cfg.in