summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical-qt5/recipes-qt/qt5
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-05-12 14:08:03 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-05-17 15:57:44 +0000
commit39b99163d3fe326d399dbe7b97546207381d8455 (patch)
treec84476fa402b45301fd0aa85d2f4620460edaf8c /meta-agl-profile-graphical-qt5/recipes-qt/qt5
parenta288d016f9e6a37377aefc2ee4df5242bb29c196 (diff)
qtwayland_%.bbappend: Force resize after buffer swap
As the qtwayland client will sometimes 'forget' to do a redraw when resizing back to the original geometry force it to happen each time at the end of the EGL buffer swap. Temporary fix until a proper one is done inside qtwayland. Bug-SPEC: SPEC-3334 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Iabf53065222a5ee803baf8ed146a11dd24a96860
Diffstat (limited to 'meta-agl-profile-graphical-qt5/recipes-qt/qt5')
-rw-r--r--meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend b/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
index 408b2b6b5..6472c7eff 100644
--- a/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
@@ -31,4 +31,5 @@ QT_SHELL_FILE = "${AFM_CONF_DIR}/qt-shell"
do_install_append_class-target() {
mkdir -p ${AFM_CONF_DIR}
echo "QT_WAYLAND_SHELL_INTEGRATION=${DEFAULT_WM_SHELL}" > ${QT_SHELL_FILE}
+ echo "QT_WAYLAND_RESIZE_AFTER_SWAP=1" >> ${QT_SHELL_FILE}
}