summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical-qt5
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-05-12 13:17:54 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-05-13 11:53:57 +0000
commit91524b2cbe2b81d9cadcb1e0a1f30df3c00078b5 (patch)
tree3cd178a711b07a4aef6018b85f48d352f04e9fd6 /meta-agl-profile-graphical-qt5
parent9ebcdd9ea2144c7112accd9b2a1a56ae7fea4449 (diff)
qtwayland_%.bbappend: Migrate the qt shell integration to the proper
place The proper place to choose the qtshell integration is with qtwayland so migrate it there. While at it, upgrade to xdg-shell stable instead of using the unstable v6. Bug-AGL: SPEC-3133 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: I67b92cd744c4e34c9a603b9535823d9562d4bdf8
Diffstat (limited to 'meta-agl-profile-graphical-qt5')
-rw-r--r--meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend b/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
index 792a09f15..408b2b6b5 100644
--- a/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/meta-agl-profile-graphical-qt5/recipes-qt/qt5/qtwayland_%.bbappend
@@ -23,3 +23,12 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
"
+
+DEFAULT_WM_SHELL = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-compositor', 'xdg-shell', 'ivi-shell', d)}"
+AFM_CONF_DIR = "${D}${sysconfdir}/afm/unit.env.d"
+QT_SHELL_FILE = "${AFM_CONF_DIR}/qt-shell"
+
+do_install_append_class-target() {
+ mkdir -p ${AFM_CONF_DIR}
+ echo "QT_WAYLAND_SHELL_INTEGRATION=${DEFAULT_WM_SHELL}" > ${QT_SHELL_FILE}
+}