summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical
diff options
context:
space:
mode:
authorMarius Vlad <marius.vlad@collabora.com>2020-06-24 19:50:55 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-06-25 08:13:17 +0000
commit1e9bc66cdd68be6d6c23c57ccc0928bdbb5cf0a6 (patch)
treee0944a3f7ddb7f3cab6c13ae68ecc20a8c8fd6fd /meta-agl-profile-graphical
parent2bf7bd0ad11069d6201514d899a9b11f5db4ccb2 (diff)
gstreamer1.0-plugins-bad: Modify meson build file to install wayland
header Removes the older patch in the process as autotools/autogen are no longer in use. Bug-AGL: SPEC-3382 Signed-off-by: Marius Vlad <marius.vlad@collabora.com> Change-Id: Ib5c99b62e5cd434bc8ebfd7c1b5460784f72e806 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/24860 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Veeresh Kadasani <external.vkadasani@jp.adit-jv.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-profile-graphical')
-rw-r--r--meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad/0001-gst-wayland-Install-wayland-header-from-gstwayland-l.patch28
-rw-r--r--meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad/0001-install-wayland.h.patch33
-rw-r--r--meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad_1.16.%.bbappend2
3 files changed, 29 insertions, 34 deletions
diff --git a/meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad/0001-gst-wayland-Install-wayland-header-from-gstwayland-l.patch b/meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad/0001-gst-wayland-Install-wayland-header-from-gstwayland-l.patch
new file mode 100644
index 000000000..443e7db8b
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad/0001-gst-wayland-Install-wayland-header-from-gstwayland-l.patch
@@ -0,0 +1,28 @@
+From 03e502084633838badfcc2b91a1aca1651c18544 Mon Sep 17 00:00:00 2001
+From: Marius Vlad <marius.vlad@collabora.com>
+Date: Wed, 24 Jun 2020 19:44:35 +0300
+Subject: [PATCH] gst/wayland/: Install wayland header from gstwayland library
+
+Necessary for cluster-receiver to pass out the wl_surface.
+
+Bug-AGL: SPEC-3382
+
+Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
+---
+ gst-libs/gst/wayland/meson.build | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/gst-libs/gst/wayland/meson.build b/gst-libs/gst/wayland/meson.build
+index b1ede41f1..8957381d2 100644
+--- a/gst-libs/gst/wayland/meson.build
++++ b/gst-libs/gst/wayland/meson.build
+@@ -21,4 +21,6 @@ if use_wayland
+ gstwayland_dep = declare_dependency(link_with : gstwayland,
+ include_directories : [libsinc],
+ dependencies : [gst_dep, gstvideo_dep])
++
++ install_headers('wayland.h', subdir: 'gst/wayland')
+ endif
+--
+2.26.2
+
diff --git a/meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad/0001-install-wayland.h.patch b/meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad/0001-install-wayland.h.patch
deleted file mode 100644
index 67481574c..000000000
--- a/meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad/0001-install-wayland.h.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 0adaad552a15dfb03d41774c4cf45b8c9a038640 Mon Sep 17 00:00:00 2001
-From: Veeresh Kadasani <external.vkadasani@jp.adit-jv.com>
-Date: Wed, 10 Jul 2019 14:36:37 +0900
-Subject: [PATCH 1/2] install wayland.h
-
-Signed-off-by: Veeresh Kadasani <external.vkadasani@jp.adit-jv.com>
----
- gst-libs/gst/wayland/Makefile.am | 6 ++----
- 1 file changed, 2 insertions(+), 4 deletions(-)
-
-diff --git a/gst-libs/gst/wayland/Makefile.am b/gst-libs/gst/wayland/Makefile.am
-index 743a489..c59b06d 100644
---- a/gst-libs/gst/wayland/Makefile.am
-+++ b/gst-libs/gst/wayland/Makefile.am
-@@ -5,6 +5,8 @@ libgstwayland_@GST_API_VERSION@_la_SOURCES = wayland.c
- libgstwayland_@GST_API_VERSION@includedir = \
- $(includedir)/gstreamer-@GST_API_VERSION@/gst/wayland
-
-+libgstwayland_@GST_API_VERSION@include_HEADERS = wayland.h
-+
- libgstwayland_@GST_API_VERSION@_la_CFLAGS = \
- $(GST_PLUGINS_BAD_CFLAGS) \
- $(GST_PLUGINS_BASE_CFLAGS) \
-@@ -21,7 +23,3 @@ libgstwayland_@GST_API_VERSION@_la_LDFLAGS = \
- $(GST_LIB_LDFLAGS) \
- $(GST_ALL_LDFLAGS) \
- $(GST_LT_LDFLAGS)
--
--noinst_HEADERS = \
-- wayland.h
--
---
-2.7.4
diff --git a/meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad_1.16.%.bbappend b/meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad_1.16.%.bbappend
index 4597428fa..7e1fa773d 100644
--- a/meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad_1.16.%.bbappend
+++ b/meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-bad/gstreamer1.0-plugins-bad_1.16.%.bbappend
@@ -1,2 +1,2 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI_append="${@bb.utils.contains_any("MACHINE", "salvator-x m3ulcb h3ulcb m3ulcb-nogfx", " "," file://0001-install-wayland.h.patch", d)}"
+SRC_URI_append="${@bb.utils.contains_any("MACHINE", "salvator-x m3ulcb h3ulcb m3ulcb-nogfx", " "," file://0001-gst-wayland-Install-wayland-header-from-gstwayland-l.patch", d)}"