summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-03-30 17:47:06 -0400
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-04-27 17:12:24 +0200
commit76fdd8c9f0532c56d65e1124801bb1054c692078 (patch)
tree0e941a39ce16d894b157c77dd74eacaa2b0b041c /meta-agl-profile-graphical
parent75903b3b663a1f94d581fff80cd1439a8c5d4fcc (diff)
meta-agl-profile-graphical: update weston for dunfell
Rename weston bbappend, remove backported patch, and update a patch for weston 8.0.0 in dunfell. Bug-AGL: SPEC-3302 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I518bd403133c193e5f68ee89e69dfccc56d5c78d
Diffstat (limited to 'meta-agl-profile-graphical')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-config-parser-Export-get_full_path-and-destroy.patch36
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston/use-XDG_RUNTIMESHARE_DIR.patch26
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.0.bbappend (renamed from meta-agl-profile-graphical/recipes-graphics/wayland/weston_7.0.0.bbappend)1
3 files changed, 14 insertions, 49 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-config-parser-Export-get_full_path-and-destroy.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-config-parser-Export-get_full_path-and-destroy.patch
deleted file mode 100644
index 9dbd7a749..000000000
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/0001-config-parser-Export-get_full_path-and-destroy.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 40ff644ac4da90c5cf5239c6ee6051d9bb2b099a Mon Sep 17 00:00:00 2001
-From: Daniel Stone <daniels@collabora.com>
-Date: Mon, 25 Nov 2019 10:30:11 +0000
-Subject: [PATCH] config-parser: Export get_full_path and destroy
-
-Make sure we export the get_full_path() accessor (declared in the
-header, used by Weston itself) and the parser's destroy function.
-
-Signed-off-by: Daniel Stone <daniels@collabora.com>
----
- shared/config-parser.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/shared/config-parser.c b/shared/config-parser.c
-index 35f09f006..94eb24cc1 100644
---- a/shared/config-parser.c
-+++ b/shared/config-parser.c
-@@ -470,6 +470,7 @@ weston_config_parse(const char *name)
- return config;
- }
-
-+WL_EXPORT
- const char *
- weston_config_get_full_path(struct weston_config *config)
- {
-@@ -500,6 +501,7 @@ weston_config_next_section(struct weston_config *config,
- return 1;
- }
-
-+WL_EXPORT
- void
- weston_config_destroy(struct weston_config *config)
- {
---
-2.21.0
-
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/use-XDG_RUNTIMESHARE_DIR.patch b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/use-XDG_RUNTIMESHARE_DIR.patch
index 2f3b0108a..0e5d7cdf9 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston/use-XDG_RUNTIMESHARE_DIR.patch
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston/use-XDG_RUNTIMESHARE_DIR.patch
@@ -29,19 +29,21 @@ remain maintained locally out of mainstream in the wait
of further investigations.
Signed-off-by: José Bollo <jose.bollo@iot.bzh>
+[Updated for Weston 8.0.0]
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
diff --git a/shared/os-compatibility.c b/shared/os-compatibility.c
-index e19fb61b..826e48b8 100644
+index 5e1ce47..9962588 100644
--- a/shared/os-compatibility.c
+++ b/shared/os-compatibility.c
-@@ -157,7 +157,9 @@ os_create_anonymous_file(off_t size)
- int fd;
- int ret;
-
-- path = getenv("XDG_RUNTIME_DIR");
-+ path = getenv("XDG_RUNTIMESHARE_DIR");
-+ if (!path)
-+ path = getenv("XDG_RUNTIME_DIR");
- if (!path) {
- errno = ENOENT;
- return -1;
+@@ -184,7 +184,9 @@ os_create_anonymous_file(off_t size)
+ } else
+ #endif
+ {
+- path = getenv("XDG_RUNTIME_DIR");
++ path = getenv("XDG_RUNTIMESHARE_DIR");
++ if (!path)
++ path = getenv("XDG_RUNTIME_DIR");
+ if (!path) {
+ errno = ENOENT;
+ return -1;
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston_7.0.0.bbappend b/meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.0.bbappend
index 67ce0ba5e..737992c62 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston_7.0.0.bbappend
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston_8.0.0.bbappend
@@ -8,7 +8,6 @@ SRC_URI_append = "\
file://0001-Allow-regular-users-to-launch-Weston_7.0.0.patch \
file://use-XDG_RUNTIMESHARE_DIR.patch \
file://0002-ivi-shell-Fix-crash-due-no-transmitter-screen.patch \
- file://0001-config-parser-Export-get_full_path-and-destroy.patch \
file://0001-libweston-Expose-weston_output_damage-in-libweston.patch \
"