summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-06-23 18:10:10 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-06-24 14:33:23 +0200
commit95b8edd4aab48f4cb66f3119e91e59ab74f907e9 (patch)
tree16ab8f0ac5ba32e6741849eede7610bcfe844925 /meta-agl-profile-graphical
parent49bd9e1a1e787e308146e4e4a1cd320ddb7e7ece (diff)
Make the agl-compositor the default compositor
This makes the agl-compositor the default starting with Jumping Jellyfish For development purposes, you have these variables at hand to influence the setup: AGL_DEFAULT_WESTONSTART AGL_DEFAULT_WM_SHELL Check your conf/local.conf for details. Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org> Change-Id: Iceb35375e04f947009800b80511f6360026403fe
Diffstat (limited to 'meta-agl-profile-graphical')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb6
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend7
2 files changed, 9 insertions, 4 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb b/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb
index c0e2d9895..41f5f027b 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/agl-compositor_git.bb
@@ -18,4 +18,8 @@ S = "${WORKDIR}/git"
inherit meson pkgconfig python3native
-FILES_${PN} = "${bindir}/agl-compositor ${datadir}/${PN}/protocols/agl-shell.xml ${datadir}/${PN}/protocols/agl-shell-desktop.xml"
+FILES_${PN} = " \
+ ${bindir}/agl-compositor \
+ ${datadir}/${PN}/protocols/agl-shell.xml \
+ ${datadir}/${PN}/protocols/agl-shell-desktop.xml \
+ "
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
index ddabff5f5..374e9aa75 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend
@@ -2,9 +2,10 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
inherit agl-graphical
-WESTONSTART ??= "${@bb.utils.contains("DISTRO_FEATURES", "agl-compositor", "/usr/bin/agl-compositor", "/usr/bin/weston",d)} ${WESTONARGS}"
-WESTONSTART_append = " ${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", " --log=${DISPLAY_XDG_RUNTIME_DIR}/weston.log", "",d)}"
-WESTONSTART_append = " ${@bb.utils.contains("DISTRO_FEATURES", "agl-compositor", " --config ${sysconfdir}/xdg/weston/weston.ini", "",d)}"
+AGL_DEFAULT_WESTONSTART ??= "/usr/bin/agl-compositor --config ${sysconfdir}/xdg/weston/weston.ini"
+
+WESTONSTART ??= "${AGL_DEFAULT_WESTONSTART} ${WESTONARGS}"
+WESTONSTART_append = " ${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", " --log=${DISPLAY_XDG_RUNTIME_DIR}/compositor.log", "",d)}"
WIFILES = " \
file://weston.conf.in \