summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-05-12 20:58:56 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-05-18 10:30:03 +0000
commitdad22a2b3c3cced169c4790e8fe5d8cf2cc62ee2 (patch)
tree72df19f3267cb0b45dfece356e4d4f5890e909b0 /meta-agl-profile-graphical
parenta954a264140745f6732695dcce9f84494504b758 (diff)
Rework test/debug image features and crosssdk image definitions
Changes include: - The agl-test-wgt/agl-devel-wgt image features and the scheme of appending to their FEATURE_PACKAGES definitions turned out to be problematic with respect to resulting in unexpected extra packages ending up in agl-image-{minimal,ivi}, etc., when building with agl-demo configured (which is typical usage). To avoid this, the FEATURE_PACKAGE definitions for the image features have been replaced with tweaks to define COMPLEMENTARY_GLOBS for the features to bring in the test/debug/coverage packages via that mechanism. - The above removes the need to define the extra test/devel packagegroups, and requires some minor tweaks to aglwgt.bbclass to use a -debug package for the debug widget instead of -dbg, to avoid collisions with the dbg-pkgs image feature. As well, the afb-test package has been added as to RDEPENDS of all test widget packages, since that seems sensible and avoids needing to explicitly adding it elsewhere. - Attempt to rework the various crosssdk image definitions to use a layered set of .inc files to remove duplication and ensure that additions to the SDK are declared once in the appropriate profile. It is likely that a clean sheet implementation would have some things coming from meta-agl-profile-graphical, so further rework may be required/desired to continue cleaning things up. Bug-AGL: SPEC-3300, SPEC-3375 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I942b61501beb41d037001b70a501f90b9a59c45d
Diffstat (limited to 'meta-agl-profile-graphical')
-rw-r--r--meta-agl-profile-graphical/conf/include/agl-profile-graphical.inc3
-rw-r--r--meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-services.bb12
2 files changed, 0 insertions, 15 deletions
diff --git a/meta-agl-profile-graphical/conf/include/agl-profile-graphical.inc b/meta-agl-profile-graphical/conf/include/agl-profile-graphical.inc
deleted file mode 100644
index 519e79199..000000000
--- a/meta-agl-profile-graphical/conf/include/agl-profile-graphical.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-# Extend image feature package definitions for agl-test-wgt and agl-devel-wgt
-FEATURE_PACKAGES_agl-test-wgt_append = " packagegroup-agl-graphical-services-test"
-FEATURE_PACKAGES_agl-devel-wgt_append = " packagegroup-agl-graphical-services-devel"
diff --git a/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-services.bb b/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-services.bb
index 0601606f2..e587ab21c 100644
--- a/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-services.bb
+++ b/meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-services.bb
@@ -3,11 +3,8 @@ LICENSE = "MIT"
inherit packagegroup
-PROVIDES = "${PACKAGES}"
PACKAGES = "\
packagegroup-agl-graphical-services \
- packagegroup-agl-graphical-services-test \
- packagegroup-agl-graphical-services-devel \
"
ALLOW_EMPTY_${PN} = "1"
@@ -16,12 +13,3 @@ RDEPENDS_${PN} = "\
${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'agl-service-mediaplayer', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'agl-service-radio', '', d)} \
"
-
-RDEPENDS_${PN}-test = "\
- ${@' '.join([x + '-test' for x in str.split(d.getVar('RDEPENDS_${PN}'))])} \
- "
-
-RDEPENDS_${PN}-devel = "\
- ${@' '.join([x + '-dbg' for x in str.split(d.getVar('RDEPENDS_${PN}'))])} \
- ${@' '.join([x + '-coverage' for x in str.split(d.getVar('RDEPENDS_${PN}'))])} \
- "