summaryrefslogtreecommitdiffstats
path: root/meta-agl/conf
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-01 23:22:37 +0200
committerGerrit Code Review <gerrit@172.30.200.200>2016-09-01 22:42:01 +0000
commit85844f4d250d1a45129455c76e467e38d3b3e92c (patch)
treeeae6ed37b93870ea9d839834c0bfede384882331 /meta-agl/conf
parentbcd5d1e36b83d39ea57ffa8b271a2256eaed49ff (diff)
Changes for building with YP 2.1.1 'krogoth'
Notable changes: - Update poky-agl.conf for YP 2.1 krogoth - change mesa bbappend to mesa_11 - TODO: check need for gallium, or replace with DRM see SPEC-237 - remote linux-yocto_3.14 as it is no longer shipped with YP 2.1 - rtl-sdr got a fix included for its packageconfig file - update 0001-disable-when-booting-over-nfs.patch - update checksums for ft2demo - TODO: check installation of test binaries - automotive-message-broker needed a workaround in the recipe - TODO: fix package and recipe - wayland-ivi-extension fix for use of autotools _AND_ cmake at the same time: only use cmake - port pulseaudio_6.0.bbappend to pulseaudio_8.0.bbappend - TODO: check patches and forward-port - agl-audio-plugin is currently disabled until ported to pulseaudio 8.0 - gstreamer1.0_1.2.3 is only used by meta-renesas, thus move it there - update dlt-daemon to 2.15 TODO: - check values in poky-agl.conf - check mesa for needed bbappends on other boards (tested qemux86 and qemux86_64) - check pulsaudio bbappend and forward-port patches (patches disabled!) - check agl-audio-plugin and forward-port (build disabled!) - check freetype bbappend wrt. installation path of test binaries - check automotive-message-broker wrt installation routines for libraries (QA failure) - check wayland-ivi-extension build and capabilities Change-Id: I553e03cc37348cba2fc4a022820157c78bb184d3 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl/conf')
-rw-r--r--meta-agl/conf/distro/poky-agl.conf153
1 files changed, 45 insertions, 108 deletions
diff --git a/meta-agl/conf/distro/poky-agl.conf b/meta-agl/conf/distro/poky-agl.conf
index 645d57adb..dd28e1248 100644
--- a/meta-agl/conf/distro/poky-agl.conf
+++ b/meta-agl/conf/distro/poky-agl.conf
@@ -1,15 +1,44 @@
+require conf/distro/poky.conf
+
+# AGL specific derivations
DISTRO = "poky-agl"
DISTRO_NAME = "Automotive Grade Linux"
-DISTRO_VERSION = "2.0.0+snapshot-${DATE}"
-DISTRO_CODENAME = "blowfish"
-SDK_VENDOR = "-pokysdk"
+DISTRO_VERSION = "3.0.0+snapshot-${DATE}"
+DISTRO_CODENAME = "chinook"
+SDK_VENDOR = "-aglsdk"
SDK_VERSION := "${@'${DISTRO_VERSION}'.replace('snapshot-${DATE}','snapshot')}"
MAINTAINER = "AGL <automotive-discussions@lists.linuxfoundation.org>"
-TARGET_VENDOR = "-poky"
+TARGET_VENDOR = "-agl"
+
+# Override these in poky based distros
+AGL_DEFAULT_DISTRO_FEATURES = "largefile systemd opengl wayland pam bluetooth bluez5"
+POKY_DEFAULT_DISTRO_FEATURES := "${AGL_DEFAULT_DISTRO_FEATURES}"
+
+QEMU_TARGETS ?= "arm aarch64 i386 x86_64"
+# Other QEMU_TARGETS "mips mips64 mips64el ppc sh4"
+
+PREMIRRORS ??= "\
+bzr://.*/.* https://download.automotivelinux.org/AGL/mirror/ \n \
+cvs://.*/.* https://download.automotivelinux.org/AGL/mirror/ \n \
+git://.*/.* https://download.automotivelinux.org/AGL/mirror/ \n \
+gitsm://.*/.* https://download.automotivelinux.org/AGL/mirror/ \n \
+hg://.*/.* https://download.automotivelinux.org/AGL/mirror/ \n \
+osc://.*/.* https://download.automotivelinux.org/AGL/mirror/ \n \
+p4://.*/.* https://download.automotivelinux.org/AGL/mirror/ \n \
+svn://.*/.* https://download.automotivelinux.org/AGL/mirror/ \n"
-LOCALCONF_VERSION = "1"
+MIRRORS =+ "\
+ftp://.*/.* https://download.automotivelinux.org/AGL/mirror/ \n \
+http://.*/.* https://download.automotivelinux.org/AGL/mirror/ \n \
+https://.*/.* https://download.automotivelinux.org/AGL/mirror/ \n"
+
+# The CONNECTIVITY_CHECK_URI's are used to test whether we can succesfully
+# fetch from the network (and warn you if not). To disable the test set
+# the variable to be empty.
+# Git example url: git://git.yoctoproject.org/yocto-firewall-test;protocol=git;rev=HEAD
+CONNECTIVITY_CHECK_URIS ?= ""
PREFERRED_PROVIDER_udev ?= "systemd"
PREFERRED_PROVIDER_udev-utils ?= "systemd"
@@ -20,121 +49,29 @@ VIRTUAL-RUNTIME_initscripts = ""
# network manager to use (possible values: systemd, connman)
VIRTUAL-RUNTIME_net_manager = "connman"
-# Override these in poky based distros
-AGL_DEFAULT_DISTRO_FEATURES = "systemd opengl wayland pam bluetooth bluez5"
-AGL_DEFAULT_EXTRA_RDEPENDS = "packagegroup-core-boot"
-AGL_DEFAULT_EXTRA_RRECOMMENDS = "kernel-module-af-packet"
-
-DISTRO_FEATURES ?= "${DISTRO_FEATURES_DEFAULT} ${DISTRO_FEATURES_LIBC} ${AGL_DEFAULT_DISTRO_FEATURES}"
-
-#DISTRO_FEATURES_APPEND = " "
+DISTRO_FEATURES_APPEND = " "
DISTRO_FEATURES_remove = "x11"
DISTRO_FEATURES_BACKFILL_CONSIDERED = "sysvinit"
-PREFERRED_VERSION_linux-yocto ?= "4.1%"
-PREFERRED_VERSION_linux-yocto_qemux86 ?= "4.1%"
-PREFERRED_VERSION_linux-yocto_qemux86-64 ?= "4.1%"
-PREFERRED_VERSION_linux-yocto_qemuarm ?= "4.1%"
-PREFERRED_VERSION_linux-yocto_qemumips ?= "4.1%"
-PREFERRED_VERSION_linux-yocto_qemumips64 ?= "4.1%"
-PREFERRED_VERSION_linux-yocto_qemuppc ?= "4.1%"
# Prefer GStreamer 1.4.x by default
-PREFERRED_VERSION_gstreamer1.0 ?= "1.4.%"
-PREFERRED_VERSION_gstreamer1.0-plugins-bad ?= "1.4.%"
-PREFERRED_VERSION_gstreamer1.0-plugins-base ?= "1.4.%"
-PREFERRED_VERSION_gstreamer1.0-plugins-good ?= "1.4.%"
-PREFERRED_VERSION_gstreamer1.0-plugins-ugly ?= "1.4.%"
-PREFERRED_VERSION_gstreamer1.0-libav ?= "1.4.%"
-PREFERRED_VERSION_gstreamer1.0-omx ?= "1.2.%"
+PREFERRED_VERSION_gstreamer1.0 ?= "1.6.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-bad ?= "1.6.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-base ?= "1.6.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-good ?= "1.6.%"
+PREFERRED_VERSION_gstreamer1.0-plugins-ugly ?= "1.6.%"
+PREFERRED_VERSION_gstreamer1.0-libav ?= "1.6.%"
+PREFERRED_VERSION_gstreamer1.0-omx ?= "1.6.%"
# Prefer libjpeg-turbo
PREFERRED_PROVIDER_jpeg = "libjpeg-turbo"
-SDK_NAME = "${DISTRO}-${TCLIBC}-${SDK_ARCH}-${IMAGE_BASENAME}-${TUNE_PKGARCH}"
-SDKPATH = "/opt/${DISTRO}/${SDK_VERSION}"
-
-DISTRO_EXTRA_RDEPENDS += " ${AGL_DEFAULT_EXTRA_RDEPENDS}"
-DISTRO_EXTRA_RRECOMMENDS += " ${AGL_DEFAULT_EXTRA_RRECOMMENDS}"
-
-POKYQEMUDEPS = "${@bb.utils.contains("INCOMPATIBLE_LICENSE", "GPL-3.0", "", "packagegroup-core-device-devel",d)}"
-DISTRO_EXTRA_RDEPENDS_append_qemuarm = " ${POKYQEMUDEPS}"
-DISTRO_EXTRA_RDEPENDS_append_qemuarm64 = " ${POKYQEMUDEPS}"
-DISTRO_EXTRA_RDEPENDS_append_qemumips = " ${POKYQEMUDEPS}"
-DISTRO_EXTRA_RDEPENDS_append_qemuppc = " ${POKYQEMUDEPS}"
-DISTRO_EXTRA_RDEPENDS_append_qemux86 = " ${POKYQEMUDEPS}"
-DISTRO_EXTRA_RDEPENDS_append_qemux86-64 = " ${POKYQEMUDEPS}"
-
-TCLIBCAPPEND = ""
-
-QEMU_TARGETS ?= "arm aarch64 i386 x86_64"
-# Other QEMU_TARGETS "mips mips64 mips64el ppc sh4"
-
-PREMIRRORS ??= "\
-bzr://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
-cvs://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
-git://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
-gitsm://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
-hg://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
-osc://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
-p4://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
-svn://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n"
-
-MIRRORS =+ "\
-ftp://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
-http://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
-https://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n"
-
-# The CONNECTIVITY_CHECK_URI's are used to test whether we can succesfully
-# fetch from the network (and warn you if not). To disable the test set
-# the variable to be empty.
-# Git example url: git://git.yoctoproject.org/yocto-firewall-test;protocol=git;rev=HEAD
-
-CONNECTIVITY_CHECK_URIS ?= ""
-
-SANITY_TESTED_DISTROS ?= " \
- poky-1.7 \n \
- poky-1.8 \n \
- poky-2.0 \n \
- Ubuntu-14.04 \n \
- Ubuntu-14.10 \n \
- Ubuntu-15.04 \n \
- Ubuntu-15.10 \n \
- Fedora-21 \n \
- Fedora-22 \n \
- CentOS-6.* \n \
- CentOS-7.* \n \
- Debian-7.* \n \
- Debian-8.* \n \
- openSUSE-project-13.2 \n \
- "
-
-# Default hash policy for distro
-BB_SIGNATURE_HANDLER ?= 'OEBasicHash'
-#
-# OELAYOUT_ABI allows us to notify users when the format of TMPDIR changes in
-# an incompatible way. Such changes should usually be detailed in the commit
-# that breaks the format and have been previously discussed on the mailing list
-# with general agreement from the core team.
-#
-OELAYOUT_ABI = "11"
-
-# add poky sanity bbclass
-INHERIT += "poky-sanity"
-
-# QA check settings - a little stricter than the OE-Core defaults
-WARN_TO_ERROR_QA = "already-stripped compile-host-path install-host-path \
- installed-vs-shipped ldflags pn-overrides rpaths staticdev \
- useless-rpaths"
-WARN_QA_remove = "${WARN_TO_ERROR_QA}"
-ERROR_QA_append = " ${WARN_TO_ERROR_QA}"
-
# using multiple BSP layers causes dangling bbappends in meta-agl-bsp
# turn it into a warning
-BB_DANGLINGAPPENDS_WARNONLY = "1"
+#BB_DANGLINGAPPENDS_WARNONLY = "1"
# enforce security-related compiler flags by default
-require conf/distro/include/security_flags.inc
+#require conf/distro/include/security_flags.inc
# required overrides, upstreamed but not merged yet:
# http://lists.openembedded.org/pipermail/openembedded-devel/2016-June/107727.html
-SECURITY_CFLAGS_pn-llvm3.3 = "${SECURITY_NO_PIE_CFLAGS}"
+#SECURITY_CFLAGS_pn-llvm3.3 = "${SECURITY_NO_PIE_CFLAGS}"