summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2017-09-14 17:16:13 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-11 14:49:03 +0000
commit1800faed9c28e6139cacf392547fd616904cf15d (patch)
tree6ff3c0326db647a9fea9a83513c982c22972de71 /meta-agl
parent655d099206541b3efada4e18d9cb4940b2bbfe25 (diff)
psplash: add animation and last message from systemd
An animated splash screen is cool. Change-Id: I39c2404513aa6edd287df8555d46fe09e79f4408 Signed-off-by: José Bollo <jose.bollo@iot.bzh> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11197 ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Stéphane Desneux <stephane.desneux@iot.bzh> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl')
-rwxr-xr-xmeta-agl/recipes-core/psplash/files/psplash-anim11
-rw-r--r--meta-agl/recipes-core/psplash/files/psplash-start.service2
-rw-r--r--meta-agl/recipes-core/psplash/psplash_git.bbappend2
3 files changed, 14 insertions, 1 deletions
diff --git a/meta-agl/recipes-core/psplash/files/psplash-anim b/meta-agl/recipes-core/psplash/files/psplash-anim
new file mode 100755
index 000000000..ac9bf674a
--- /dev/null
+++ b/meta-agl/recipes-core/psplash/files/psplash-anim
@@ -0,0 +1,11 @@
+#/bin/bash
+
+psplash-default "$@" &
+sleep .2
+while :; do
+ for x in 0 1 2 3 4 5 6 7 8 9 10 -9 -8 -7 -6 -5 -4 -3 -2 -1 0 -1 -2 -3 -4 -5 -6 -7 -8 -9 10 9 8 7 6 5 4 3 2 1; do
+ psplash-write "PROGRESS ${x}0" || exit 0
+ psplash-write "MSG $(journalctl -n1 -ocat)" || exit 0
+ sleep .1
+ done
+done
diff --git a/meta-agl/recipes-core/psplash/files/psplash-start.service b/meta-agl/recipes-core/psplash/files/psplash-start.service
index 67619d378..d3b6940d0 100644
--- a/meta-agl/recipes-core/psplash/files/psplash-start.service
+++ b/meta-agl/recipes-core/psplash/files/psplash-start.service
@@ -6,7 +6,7 @@ DefaultDependencies=no
[Service]
ExecStartPre=/bin/sh -c "if [ -e /sys/class/graphics/fbcon/cursor_blink ]; then echo 0 > /sys/class/graphics/fbcon/cursor_blink; fi"
-ExecStart=/usr/bin/psplash -n -a 90
+ExecStart=/bin/bash -c "/usr/bin/psplash-anim -n -a 90"
[Install]
WantedBy=sysinit.target
diff --git a/meta-agl/recipes-core/psplash/psplash_git.bbappend b/meta-agl/recipes-core/psplash/psplash_git.bbappend
index c2c58c562..bdc196b6f 100644
--- a/meta-agl/recipes-core/psplash/psplash_git.bbappend
+++ b/meta-agl/recipes-core/psplash/psplash_git.bbappend
@@ -3,6 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
SRC_URI += "file://psplash-colors.h \
file://psplash-start.service \
file://psplash-quit.service \
+ file://psplash-anim \
"
SPLASH_IMAGES="file://psplash-poky-img.h;outsuffix=default"
@@ -22,4 +23,5 @@ do_install_append () {
install -d ${D}${systemd_unitdir}/system
install -m 644 ${WORKDIR}/*.service ${D}/${systemd_unitdir}/system
fi
+ install -m 755 ${WORKDIR}/psplash-anim ${D}/${bindir}
}