summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2017-10-12 09:20:19 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-12 21:50:49 +0000
commit1f94c21af983630e88e4d7230c817e5e570c6055 (patch)
tree10ff1d8b75ecf9777968868d29957295275e09f9 /meta-agl
parent151ea4141d2e332b706241aebbd3fb5b206b0072 (diff)
weston-ini-conf: Make this track variables correctly for signatures
bitbake does not know to track values that are found and used via getVarFlags() without them being otherwise refernced and tracked in ways that are otherwise caught. Further given that we use multiple levels of varflags here we need to be explicit in their tracking. Add all variables that we use to varflags where they are added to the metadata. Bug-AGL: SPEC-939 Change-Id: I32cf16c4354d733e086c6ea9a845934beff94715 Signed-off-by: Tom Rini <trini@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11255 Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf4
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf.bb1
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_DSI.inc2
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_GeChic.inc2
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_dell.inc2
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_eGalax.inc2
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_qemu.inc2
7 files changed, 11 insertions, 4 deletions
diff --git a/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf b/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf
index ec658ce7d..eb30a9a96 100644
--- a/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf
+++ b/meta-agl/recipes-graphics/wayland/Readme.weston-ini-conf
@@ -1,9 +1,5 @@
#Generate a weston.ini file:
-# WARNING Due to a bug in Yocto cache, changes in related bbappand are not detected
-# Work-around:
-# bitbake weston-ini-conf -c clean ; bitbake weston-ini-conf -c cleansstate
-
To generate the weston.ini file:
'''
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb b/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb
index 986a9eda9..c7eee62ce 100644
--- a/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf.bb
@@ -50,6 +50,7 @@ python do_generate_weston_init() {
#ar_src = d.getVarFlag('ARCHIVER_MODE', 'src', True)
addtask do_generate_weston_init after do_compile before do_install
+do_generate_weston_init[vardeps] = "DEFAULT_SCREEN WESTONCORE WESTONSHELL WESTONOUTPUT1 WESTONSECTION"
do_install_append() {
WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_DSI.inc b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_DSI.inc
index d5d91bf68..e0b39b3a3 100644
--- a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_DSI.inc
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_DSI.inc
@@ -1,2 +1,4 @@
SCREEN_DSI[name] ?= "DSI-1"
SCREEN_DSI[transform] ?= "270"
+
+do_generate_weston_init[vardeps] += "SCREEN_DSI"
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_GeChic.inc b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_GeChic.inc
index d82b18027..846e0592e 100644
--- a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_GeChic.inc
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_GeChic.inc
@@ -2,3 +2,5 @@ SCREEN_GECHIC[name] ?= "HDMI-A-1"
SCREEN_GECHIC[transform] ?= "270"
# for 1080p on GeChic 1502i:
SCREEN_GECHIC[mode] = "173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync"
+
+do_generate_weston_init[vardeps] += "SCREEN_GECHIC"
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_dell.inc b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_dell.inc
index 051e2ee0d..9d4119120 100644
--- a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_dell.inc
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_dell.inc
@@ -1,2 +1,4 @@
SCREEN_DELL[name]?="HDMI-A-1"
SCREEN_DELL[transform]?="180"
+
+do_generate_weston_init[vardeps] += "SCREEN_DELL"
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_eGalax.inc b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_eGalax.inc
index 4d3649f13..ecbba19e6 100644
--- a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_eGalax.inc
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_eGalax.inc
@@ -1,2 +1,4 @@
SCREEN_eGalax[name] ?= "HDMI-A-1"
SCREEN_eGalax[transform] ?= "90"
+
+do_generate_weston_init[vardeps] += "SCREEN_eGalax"
diff --git a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_qemu.inc b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_qemu.inc
index 76dd8b81f..c7f3abeba 100644
--- a/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_qemu.inc
+++ b/meta-agl/recipes-graphics/wayland/weston-ini-conf/screen_qemu.inc
@@ -14,3 +14,5 @@ SCREEN_QEMU[mode]?="1600x900"
#mode=800x600
#mode=848x480
#mode=640x480
+
+do_generate_weston_init[vardeps] += "SCREEN_QEMU"