summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2017-10-10 17:32:57 +0300
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-10-11 09:11:26 +0000
commit2698d8a0d86078bacfe38edd5678ffa48d1bfc94 (patch)
tree87fcd97292a04cea4403801bb7a7ccc395386dd2 /meta-agl
parent718422057615878c92a5075cdc9ca6dda188d5e2 (diff)
weston: Launch even without input devices
Fix the recurring bug and launch Weston 2.0 even if there are no input devices such a keyboard or a mouse. Bug-AGL: SPEC-936 Change-Id: I9c92ce7762626fd5df40224b53317c1239a4bd6f Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11203 Reviewed-by: Thomas Rini <trini@konsulko.com> Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Changhyeok Bae <changhyeok.bae@gmail.com> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch27
-rw-r--r--meta-agl/recipes-graphics/wayland/weston_2.0.0.bbappend1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch b/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch
new file mode 100644
index 000000000..6b47b5e89
--- /dev/null
+++ b/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch
@@ -0,0 +1,27 @@
+From 9da4f513547b4a4f0972cc718b55ba3fc5271c87 Mon Sep 17 00:00:00 2001
+From: Leon Anavi <leon.anavi@konsulko.com>
+Date: Tue, 10 Oct 2017 17:21:09 +0300
+Subject: [PATCH] compositor-drm.c: Launch without input devices
+
+Launch Weston 2.0 even if there are no input devices.
+
+Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
+---
+ libweston/compositor-drm.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/libweston/compositor-drm.c b/libweston/compositor-drm.c
+index 1d38f05..afe0dea 100644
+--- a/libweston/compositor-drm.c
++++ b/libweston/compositor-drm.c
+@@ -3278,7 +3278,6 @@ drm_backend_create(struct weston_compositor *compositor,
+ compositor, b->udev, seat_id,
+ config->configure_device) < 0) {
+ weston_log("failed to create input devices\n");
+- goto err_sprite;
+ }
+
+ b->connector = config->connector;
+--
+2.7.4
+
diff --git a/meta-agl/recipes-graphics/wayland/weston_2.0.0.bbappend b/meta-agl/recipes-graphics/wayland/weston_2.0.0.bbappend
index 65f34bc24..32df379b3 100644
--- a/meta-agl/recipes-graphics/wayland/weston_2.0.0.bbappend
+++ b/meta-agl/recipes-graphics/wayland/weston_2.0.0.bbappend
@@ -2,6 +2,7 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
SRC_URI_append = "\
file://0001-Allow-regular-users-to-launch-Weston_2.0.0.patch \
+ file://0001-compositor-drm.c-Launch-without-input-devices.patch \
"
EXTRA_OECONF_append = " --enable-sys-uid"