summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-02-28 19:28:27 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2018-03-30 08:02:11 +0000
commit36a9734e1914e08351d5150cb3fbfe0d51553dad (patch)
treef3e57640cfc7cacd86893562dd02a0818ed5fa53 /meta-agl
parent6ee7bd778686215048a2df9ea10645d17b232002 (diff)
weston-init: Ensure setting of the user
The user was not set to the expected value because the patched file had not indication of user. This fix enforce the setting of the user. It also enforce the setting of the group. Bug-AGL: SPEC-546 Change-Id: I929bfa17c541c5334f463cd8cb3566dc5b53b408 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-graphics/wayland/weston-init.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston-init.bbappend b/meta-agl/recipes-graphics/wayland/weston-init.bbappend
index 01984a13c..1ca63b5de 100644
--- a/meta-agl/recipes-graphics/wayland/weston-init.bbappend
+++ b/meta-agl/recipes-graphics/wayland/weston-init.bbappend
@@ -17,7 +17,15 @@ do_install_append() {
sed -i "/\[Service\]/r ${S}/weston.service.add" \
${D}${systemd_system_unitdir}/weston.service
+ if ! grep -q '^Group=' ${D}${systemd_system_unitdir}/weston.service; then
+ sed -i "/\[Service\]/aGroup=root" ${D}${systemd_system_unitdir}/weston.service
+ fi
+ if ! grep -q '^User=' ${D}${systemd_system_unitdir}/weston.service; then
+ sed -i "/\[Service\]/aUser=root" ${D}${systemd_system_unitdir}/weston.service
+ fi
+
sed -e 's,User=root,User=${WESTONUSER},g' \
+ -e 's,Group=root,Group=${WESTONGROUP},g' \
-e 's,ExecStart=.*,ExecStart=${WESTONSTART},g' \
-e 's,@WESTONTTY@,${WESTONTTY},g' \
-e 's,@XDG_RUNTIME_DIR@,${DISPLAY_XDG_RUNTIME_DIR},g' \