summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-02-13 17:11:31 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2018-02-13 17:11:31 +0100
commit68d2193f53bbb588680a71571485d1fe370662eb (patch)
tree610c5008efde7b4cd6ee880aad8014812bb1dc71 /meta-agl
parent0ffb178ea81ebcde3990dd8269ccc08ebbc83416 (diff)
run-(agl-)postinst: Emit progress to console
It can be useful to get the progression of the postinstallation scripts. Change-Id: I21f70ee1a5cae36c924a1c664855ba4179b5acd7 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service1
-rw-r--r--meta-agl/recipes-devtools/run-postinsts/run-postinsts_%.bbappend5
2 files changed, 6 insertions, 0 deletions
diff --git a/meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service b/meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service
index 61d6d4679..8f8667db6 100644
--- a/meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service
+++ b/meta-agl/recipes-devtools/run-agl-postinsts/run-agl-postinsts/run-agl-postinsts.service
@@ -7,6 +7,7 @@ ConditionPathExists=#SYSCONFDIR#/agl-postinsts
[Service]
Type=oneshot
+StandardOutput=journal+console
ExecStart=#SBINDIR#/run-agl-postinsts
ExecStartPost=#BASE_BINDIR#/systemctl disable run-agl-postinsts.service
RemainAfterExit=No
diff --git a/meta-agl/recipes-devtools/run-postinsts/run-postinsts_%.bbappend b/meta-agl/recipes-devtools/run-postinsts/run-postinsts_%.bbappend
new file mode 100644
index 000000000..fc327b6ef
--- /dev/null
+++ b/meta-agl/recipes-devtools/run-postinsts/run-postinsts_%.bbappend
@@ -0,0 +1,5 @@
+do_configure_append() {
+ if ! grep -q StandardOutput= ${WORKDIR}/run-postinsts.service; then
+ sed -i '/ExecStart=/iStandardOutput=journal+console' ${WORKDIR}/run-postinsts.service
+ fi
+}